(hdu 1754) I Hate It(線段樹基礎,單點更新)

feng_zhiyu發表於2017-08-10

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 81074 Accepted Submission(s): 31166

Problem Description
很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。

不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模擬老師的詢問。當然,老師有時候需要更新某位同學的成績。

Input
本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別代表學生的數目和操作的數目。
學生ID編號分別從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (只取’Q’或’U’) ,和兩個正整數A,B。
當C為’Q’的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為’U’的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。

Output
對於每一次詢問操作,在一行裡面輸出最高成績。

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9

Hint
Huge input,the C function scanf() will work better than cin

Author
linle

Source
2007省賽集訓隊練習賽(6)_linle專場

分析:單點更新

951MS 3920K 1407 B C++

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const int N=2e5+5;
int sum[N<<2],a[N],MAX[N<<2];
void pushup(int rt)
{
    //sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%d",&MAX[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int p,int c,int l,int r,int rt)
{
    if(l==r)
    {
        MAX[rt]=c;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) update(p,c,lson);
    else update(p,c,rson);
    pushup(rt);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return MAX[rt];
    }
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m) ret=max(ret,query(L,R,lson));
    if(R>m) ret=max(ret,query(L,R,rson));
    return ret;
}
int main()
{
    int t,cas=1;
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        char op;
        int a,b;
        for(int i=1; i<=m; i++)
        {
            scanf(" %c%d%d",&op,&a,&b);
            if(op=='Q')
            {
                printf("%d\n",query(a,b,1,n,1));
            }
            else if(op=='U')
                update(a,b,1,n,1);
        }
    }
    return 0;
}

相關文章