ZOJ Problem Set - 1944 Tree Recovery(二叉樹三種遍歷知二求三)

hushhw發表於2017-11-27

Tree Recovery

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations:

         D
        / \
       /   \
      B     E
     / \     \
    /   \     \
   A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.


Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).


Sample Input

DBACEGF ABCDEFG
BCAD CBAD


Sample Output

ACBFGED
CDAB


題目大意:

已知先序遍歷和中序遍歷字串,求後序遍歷


解題思路:

已知先序和中序,可以唯一的確定後續

已知後序和中序,可以唯一的確定先序

但是已知先序和後續,不能唯一確定中序

回到題目,先根據先序和中序確定根節點位置,然後用遞迴來求子樹


AC:

#include <cstdio>
#include <iostream>
#include <string>
using namespace std;

string strPost;

void PostOrder(string pre, string in)
{
	int iPos;
	if(pre == "" || in == "")
		return;
	iPos = in.find(pre[0]);
	PostOrder(pre.substr(1, iPos), in.substr(0, iPos));
	//substr的用法是返回一個新的string(即子串),第一位表示起始地址,第二位表示後面的多少位
	PostOrder(pre.substr(iPos + 1), in.substr(iPos+1));
	strPost += pre[0];
}

int main()
{
	string pre,in;
	while(cin>>pre>>in)
	{
		strPost = "";
		PostOrder(pre, in);
		cout<<strPost<<endl;
	}
	return 0;
}


完整:

#include <cstdio>
#include <iostream>
#include <string>
using namespace std;

string strPost;
string strPre;

void PostOrder(string pre, string in)
{
	int iPos;
	if(pre == "" || in == "")
		return;
	iPos = in.find(pre[0]);
	PostOrder(pre.substr(1, iPos), in.substr(0, iPos));
	//substr的用法是返回一個新的string(即子串),第一位表示起始地址,第二位表示後面的多少位
	PostOrder(pre.substr(iPos + 1), in.substr(iPos+1));
	strPost += pre[0];
}

void PreOrder(string in, string post)
{
	long iPos;
	if(in == "" || post == "")
		return;
	iPos = in.find(post[post.size()-1]);
	strPre += post[post.size()-1];
	PreOrder(in.substr(0,iPos), post.substr(0, iPos));
	PreOrder(in.substr(iPos + 1, in.size() - iPos -1), post.substr(iPos, post.size() - iPos - 1) );
}

int main()
{
	string pre,in,post;
	while(cin>>pre>>in>>post)
	{
		strPost = "";
		PostOrder(pre, in);
		PreOrder(in, post);
		cout<<strPost<<endl;
		cout<<strPre<<endl;
	}
	return 0;
}


相關文章