ZOJ Problem Set - 1944 Tree Recovery(二叉樹三種遍歷知二求三)
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
D
/ \
/ \
B E
/ \ \
/ \ \
A C G
/
/
F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree,
root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
題目大意:
已知先序遍歷和中序遍歷字串,求後序遍歷
解題思路:
已知先序和中序,可以唯一的確定後續
已知後序和中序,可以唯一的確定先序
但是已知先序和後續,不能唯一確定中序
回到題目,先根據先序和中序確定根節點位置,然後用遞迴來求子樹
AC:
#include <cstdio>
#include <iostream>
#include <string>
using namespace std;
string strPost;
void PostOrder(string pre, string in)
{
int iPos;
if(pre == "" || in == "")
return;
iPos = in.find(pre[0]);
PostOrder(pre.substr(1, iPos), in.substr(0, iPos));
//substr的用法是返回一個新的string(即子串),第一位表示起始地址,第二位表示後面的多少位
PostOrder(pre.substr(iPos + 1), in.substr(iPos+1));
strPost += pre[0];
}
int main()
{
string pre,in;
while(cin>>pre>>in)
{
strPost = "";
PostOrder(pre, in);
cout<<strPost<<endl;
}
return 0;
}
完整:
#include <cstdio>
#include <iostream>
#include <string>
using namespace std;
string strPost;
string strPre;
void PostOrder(string pre, string in)
{
int iPos;
if(pre == "" || in == "")
return;
iPos = in.find(pre[0]);
PostOrder(pre.substr(1, iPos), in.substr(0, iPos));
//substr的用法是返回一個新的string(即子串),第一位表示起始地址,第二位表示後面的多少位
PostOrder(pre.substr(iPos + 1), in.substr(iPos+1));
strPost += pre[0];
}
void PreOrder(string in, string post)
{
long iPos;
if(in == "" || post == "")
return;
iPos = in.find(post[post.size()-1]);
strPre += post[post.size()-1];
PreOrder(in.substr(0,iPos), post.substr(0, iPos));
PreOrder(in.substr(iPos + 1, in.size() - iPos -1), post.substr(iPos, post.size() - iPos - 1) );
}
int main()
{
string pre,in,post;
while(cin>>pre>>in>>post)
{
strPost = "";
PostOrder(pre, in);
PreOrder(in, post);
cout<<strPost<<endl;
cout<<strPre<<endl;
}
return 0;
}
相關文章
- 二叉樹(BST)中序遍歷的三種方法二叉樹
- 二叉樹的前序、中序、後序三種遍歷二叉樹
- 一文弄懂二叉樹的三種遍歷方式二叉樹
- 二叉樹四種遍歷二叉樹
- Python實現二叉樹的三種深度遍歷方法!Python二叉樹
- 二叉樹---遍歷二叉樹
- 二叉樹遍歷二叉樹
- 二叉樹遍歷方法二叉樹
- 二叉樹遍歷 -- JAVA二叉樹Java
- 二叉樹的遍歷二叉樹
- JAVA遍歷二叉樹Java二叉樹
- 【LeetCode 100_二叉樹_遍歷】Same TreeLeetCode二叉樹
- C++樹——遍歷二叉樹C++二叉樹
- POJ2255Tree Recovery(二叉樹)二叉樹
- 完全二叉樹的遍歷二叉樹
- 迴圈遍歷二叉樹二叉樹
- 二叉樹--後序遍歷二叉樹
- 層序遍歷二叉樹二叉樹
- 【圖解資料結構】 一組動畫徹底理解二叉樹三種遍歷圖解資料結構動畫二叉樹
- 根據二叉樹的前序遍歷和中序遍歷輸出二叉樹;二叉樹
- 玩轉二叉樹(樹的遍歷)二叉樹
- 144.二叉樹的前序遍歷145.二叉樹的後序遍歷 94.二叉樹的中序遍歷二叉樹
- Construct Binary Tree from Preorder and Inorder Traversal(前序遍歷和中序遍歷樹構造二叉樹)...Struct二叉樹
- 二叉樹的廣度遍歷和深度遍歷()二叉樹
- 【LeetCode-二叉樹】二叉樹前序遍歷LeetCode二叉樹
- MySQL樹形遍歷(三)MySql
- 二叉樹的遍歷實現二叉樹
- 二叉樹的遍歷筆記二叉樹筆記
- 二叉樹的層序遍歷二叉樹
- 二叉樹的按層遍歷二叉樹
- 二叉樹遍歷方法總結二叉樹
- 【練習】二叉樹的遍歷二叉樹
- 二叉樹的建立與遍歷二叉樹
- 二叉樹非遞迴遍歷二叉樹遞迴
- UVA 536 二叉樹的遍歷二叉樹
- 6.14-二叉樹遍歷二叉樹
- 二叉樹建立,前序遍歷,中序遍歷,後序遍歷 思路二叉樹
- 二叉樹的建立、前序遍歷、中序遍歷、後序遍歷二叉樹