HDU 1575 Tr A【矩陣快速冪取模】

DTL66發表於2016-11-09

Tr A

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4510    Accepted Submission(s): 3394


Problem Description
A為一個方陣,則Tr A表示A的跡(就是主對角線上各項的和),現要求Tr(A^k)%9973。
 

Input
資料的第一行是一個T,表示有T組資料。
每組資料的第一行有n(2 <= n <= 10)和k(2 <= k < 10^9)兩個資料。接下來有n行,每行有n個資料,每個資料的範圍是[0,9],表示方陣A的內容。
 

Output
對應每組資料,輸出Tr(A^k)%9973。
 

Sample Input
2 2 2 1 0 0 1 3 99999999 1 2 3 4 5 6 7 8 9
 

Sample Output
2 2686



AC程式碼:

#include<cstdio> 
#include<cstring>

typedef long long LL;
const int MOD=9973;
const int MAXN=13;

typedef struct Matrix{
	int M[MAXN][MAXN];
	int n,m;
	void clear() {
		memset(M,0,sizeof(M)); n=m=0;
	}
	Matrix operator *(const Matrix &a) const {
		Matrix tem; tem.clear();
		tem.n=n, tem.m=a.m;
		for(int i=0;i<n;++i )  {
			for(int j=0;j<m;++j)  if(M[i][j]) {
				for(int k=0;k<a.m;++k) {
					tem.M[i][k]=(tem.M[i][k]+(M[i][j]%MOD*(a.M[j][k]%MOD))%MOD)%MOD;
				}
			}
		}
		return tem;
	} 
//	const Matrix operator %(int MOD) {
//		Matrix tem; tem.clear();
//		for(int i=0;i<n;++i) {
//			for(int j=0;j<m;++j) if(M[i][j]) tem.M[i][j]=M[i][j]%MOD;
//		}
//		return tem;
//	}
	Matrix& operator =(const Matrix& a) {
		for(int i=0;i<=a.n;++i) {
			for(int j=0;j<=a.m;++j) M[i][j]=a.M[i][j];
		}  
		return *this;
	} 
}Matrix; 

LL Pow_Mod(Matrix base,LL y,int MOD)
{
	Matrix ans; ans.clear(); ans.m=ans.n=base.m;
	for(int i=0;i<ans.m;++i) ans.M[i][i]=1;
	while(y) {
		if(y&1) ans=base*ans;
		y>>=1; base=base*base;
	}
	LL cnt=0;
	for(int i=0;i<ans.n;++i ) cnt=(cnt+ans.M[i][i])%MOD;
	return cnt;
}
int main()
{
	int T; scanf("%d",&T);
	while(T--) {
		int N,K; scanf("%d%d",&N,&K);
	    Matrix a; a.m=N; a.n=N;
	    for(int i=0;i<N;++i) for(int j=0;j<N;++j) scanf("%d",&a.M[i][j]);
		printf("%lld\n",Pow_Mod(a,K,MOD)); 
	}
    return 0;	
}  


相關文章