C/C++—— 輸入兩點座標(X1,Y1),(X2,Y2),計算並輸出兩點間的距離

readyao發表於2016-03-22

Problem Description
輸入兩點座標(X1,Y1),(X2,Y2),計算並輸出兩點間的距離。
Input
輸入資料有多組,每組佔一行,由4個實陣列成,分別表示x1,y1,x2,y2,資料之間用空格隔開。
Output
對於每組輸入資料,輸出一行,結果保留兩位小數。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41

考察點:浮點數輸出小數點後的兩位數字。迴圈輸入(linux系統按下Ctrl+d退出while輸入迴圈)

原始碼:

#include <iostream>
#include <math.h>
#include <iomanip>

using namespace std;


int main()
{
    double x1, y1, x2, y2;
    double distance;

    while(cin >> x1 >> y1 >> x2 >> y2){
        distance = sqrt(pow(x2-x1, 2) + pow(y2-y1, 2));
        cout << setprecision(2) << fixed << distance << endl;
    }


    return 0;
}

輸出:
root@linux_ever:~/linux_ever/work_test# ./two_points_distance 
0 0 0 1
1.00
0 1 1 0
1.41

題目連結:http://acm.acmcoder.com/showproblem.php?pid=2001

已提交成功:


相關文章