HDU Piggy-Bank(完全揹包問題)
Piggy-Bank
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35106 Accepted Submission(s): 17448
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
Source
這是一個典型的完全揹包問題。
#include<stdio.h>
#define INF 0x3fffffff
int E,F;
int p[505];
int w[505];
int dp[505][10005];
int min(int a,int b)
{
return (a<b)?a:b;
}
int main()
{
int N,M;
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d %d",&E,&F);
scanf("%d",&N);
int i,j;
for(i=1;i<=N;i++)
{
scanf("%d %d",&p[i],&w[i]);
}
for(j=0;j<=(F-E);j++)
{
dp[0][j]=INF;
}
dp[0][0]=0;
for(i=1;i<=N;i++)
{
for(j=0;j<=(F-E);j++)
{
if(j>=w[i]&&dp[i][j-w[i]]!=INF) dp[i][j]=min(dp[i-1][j],dp[i][j-w[i]]+p[i]);//等於符號萬萬不可少
else dp[i][j]=dp[i-1][j];
}
}
if(dp[N][F-E]==INF) printf("This is impossible.\n");
else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[N][F-E]);
}
return 0;
}
相關文章
- HDU - 1114 Piggy-Bank(完全揹包板題)
- 揹包問題(01揹包與完全揹包)
- 01揹包和完全揹包問題解法模板
- 從【零錢兌換】問題看01揹包和完全揹包問題
- 揹包DP——完全揹包
- Codeup 貨幣系統(完全揹包問題)
- 分組揹包、完全揹包
- 【模板】01揹包、完全揹包
- hdu6007 Mr. Panda and Crystal (最短路+完全揹包)
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- 01揹包、完全揹包、多重揹包詳解
- 揹包問題
- hdu3591The trouble of Xiaoqian 多重揹包+全然揹包
- 圖解二維完全揹包問題——降維打擊圖解
- dp-完全揹包
- 01揹包問題
- 01 揹包問題
- 揹包問題大合集
- 經典揹包問題
- 005多重揹包問題||
- 部分揹包問題(挖
- 揹包九講問題
- HDU - 2191 珍惜現在,感恩生活(多重揹包板題)
- javascript演算法基礎之01揹包,完全揹包,多重揹包實現JavaScript演算法
- 揹包問題例題總結
- 2. 01揹包問題
- 【leetcode】揹包問題彙總LeetCode
- 揹包問題解題方法總結
- JavaScript中揹包問題(面試題)JavaScript面試題
- 51nod 1597 有限揹包計數問題 (揹包 分塊)
- 【程式碼隨想錄】完全揹包
- 二維費用揹包問題
- chapter12-2-揹包問題APT
- 深入剖析多重揹包問題(上篇)
- 深入剖析多重揹包問題(下篇)
- 關於各種揹包問題
- 【動態規劃】揹包問題動態規劃
- 01揹包問題的解決