HDU5831(2016多校第八場)———Rikka with Parenthesis II(水題)

say_c_box發表於2016-08-11

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 16    Accepted Submission(s): 16


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.


#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
using namespace std;
const int MAXN =100000+10;
const int INF =1000000007;
char a[MAXN];
int main()
{
    //freopen("in.txt","r+",stdin);
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        getchar();
        scanf("%s",a);
        int res=0;
        if(n%2==1){
            printf("No\n");
            continue;
        }
        if(n==2){
            if(a[0]=='('&&a[1]==')'){
                printf("No\n");
            }
            else{
                printf("Yes\n");
            }
            continue;
        }
        int ok=1;
        int flag=1;
        for(int i=0;i<n;i++){
            if(a[i]=='(')
                res++;
            else
                res--;
            if(res<0&&flag){
                for(int j=n-1;j>i;j--){
                    if(a[j]=='('){
                        swap(a[i],a[j]);
                        res=1;
                        flag=0;
                        break;
                    }
                }
            }
            else if(flag==0&&res<0)
            {
                ok=0;
                break;
            }
        }
        if(!ok){
            printf("No\n");
            continue;
            }
        if(res!=0){
            printf("No\n");
            continue;
        }
        printf("Yes\n");
    }
}














相關文章