HDU5831(2016多校第八場)———Rikka with Parenthesis II(水題)
Rikka with Parenthesis II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 16 Accepted Submission(s): 16
Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:
Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".
Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj.
Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.
It is too difficult for Rikka. Can you help her?
Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".
Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj.
Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.
It is too difficult for Rikka. Can you help her?
Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100
For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
Output
For each testcase, print "Yes" or "No" in a line.
Sample Input
3
4
())(
4
()()
6
)))(((
Sample Output
Yes
Yes
No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
using namespace std;
const int MAXN =100000+10;
const int INF =1000000007;
char a[MAXN];
int main()
{
//freopen("in.txt","r+",stdin);
int t;
scanf("%d",&t);
while(t--){
int n;
scanf("%d",&n);
getchar();
scanf("%s",a);
int res=0;
if(n%2==1){
printf("No\n");
continue;
}
if(n==2){
if(a[0]=='('&&a[1]==')'){
printf("No\n");
}
else{
printf("Yes\n");
}
continue;
}
int ok=1;
int flag=1;
for(int i=0;i<n;i++){
if(a[i]=='(')
res++;
else
res--;
if(res<0&&flag){
for(int j=n-1;j>i;j--){
if(a[j]=='('){
swap(a[i],a[j]);
res=1;
flag=0;
break;
}
}
}
else if(flag==0&&res<0)
{
ok=0;
break;
}
}
if(!ok){
printf("No\n");
continue;
}
if(res!=0){
printf("No\n");
continue;
}
printf("Yes\n");
}
}
相關文章
- HDU 5831 Rikka with Parenthesis II (括號匹配)
- [DP]HDU6415(2018多校訓練賽第九場 Problem A) Rikka with Nash Equilibrium 題解UI
- #1280 : Rikka with Sequence II [meet int the middle]
- HDU5425Rikka with Tree II(數學期望)
- 【記憶優化搜尋/dp】HDU - 6415 - 杭電多校第九場 - Rikka with Nash Equilibrium優化UI
- HDU5424Rikka with Graph II(哈密頓圖判斷)
- HDU 5389 Zero Escape(2015年多校聯合第八場 動態規劃)動態規劃
- 杭電多校補題
- 【dp+組合數學】hdu 2018 多校第九場 1001 Rikka with Nash Equilibrium hdu 6415UI
- 24牛客多校第一場
- 牛客多校H題題解
- 2024牛客多校第三場
- 2024牛客多校第四場
- 2024牛客多校第七場
- 2024杭電多校第8場
- 2024杭電多校第九場
- 2024杭電多校第9場
- 2024牛客多校第10場
- [ABC223F] Parenthesis Checking 題解
- 【leetcode 簡單】 第八十五題 兩個陣列的交集 IILeetCode陣列
- 題解:AT_arc175_b [ARC175B] Parenthesis Arrangemen
- 2024牛客多校第一場 - Mirror Maze
- 山東省第八屆 ACM 省賽 quadratic equation (水、坑)ACM
- 第八章 多型多型
- 2016騰訊校招面試分享面試
- 2016年美的校招面試面試
- 2016蘭亭校招C++C++
- 2014多校聯合第9場1011題||hdu 4970 樹狀陣列陣列
- 英語II題庫
- 【DFS】HDU 5423 Rikka with Tree
- HDU4965Fast Matrix Calculation(2014多校第九場)AST
- 2016校招,Android開發,常見面試問題彙總Android面試
- 演算法概論 第八章第八題演算法
- 3 月水題練習
- 藍橋杯第 3 場 演算法季度賽第八題 升級電纜題解演算法
- 第八章習題
- 現場拆題+直通面試 | 美團技術校招直播來了!面試
- 牛客網暑期ACM多校訓練營(第三場)C Shuffle Cards(splay)ACM