1118. Birds in Forest (25)

一名路過的小碼農啊發表於2017-03-25

1118. Birds in Forest (25)

時間限制
150 ms
記憶體限制
65536 kB
程式碼長度限制
16000 B
判題程式
Standard
作者
CHEN, Yue

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
並查集,好久不寫都生疏了。。。
#include<iostream>
#include<cstdio>
#include<cstring>
int pre[10005];
bool isroot[10005];
int findfather(int a)
{
	return pre[a]==a?pre[a]:findfather(pre[a]);
}
void Union(int a,int b)
{
	int aa=findfather(a);
	int bb=findfather(b);
	if(aa!=bb)
	{
		pre[aa]=bb;
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=10000;i++)
		pre[i]=i;
	int max=0;
	int index=0;
	memset(isroot,false,sizeof(isroot));
	for(int i=1;i<=n;i++)
	{
		int k;
		scanf("%d",&k);
		for(int j=0;j<k;j++)
		{
			int bird;
			scanf("%d",&bird);
			if(j==0)
			{
				index=bird;
			}
			if(max<bird)max=bird;
			Union(index,bird);
		}
	}
	for(int i=1;i<=max;i++)
	{
		isroot[findfather(i)]=true;
	}
	int cnt=0;
	for(int i=1;i<=max;i++)
	{
		if(isroot[i])cnt++;
	}
	printf("%d %d\n",cnt,max);
	int q;
	scanf("%d",&q);
	for(int i=0;i<q;i++)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		if(findfather(a)!=findfather(b))
		{
			printf("No\n");
		}
		else printf("Yes\n");
	}

	return 0;
}


相關文章