POJ 1743 Musical Theme (字尾陣列,求最長不重疊重複子串)

weixin_33894992發表於2013-04-23
Musical Theme
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 14334   Accepted: 4945

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

Source

 
 
 
 
字尾陣列做的第一道題目~~~~
 
方法可以看論文,有詳細的解釋。
 
 
/*
 * POJ 1743 Musical Theme
 * 有N(1 <= N <=20000)個音符的序列來表示一首樂曲,每個音符都是1..88範圍內的整數,現在要找一個重複的主題。
 * “主題”是整個音符序列的一個子串,它需要滿足如下條件:
 * 1.長度至少為5個音符
 * 2.在樂曲中重複出現(可能經過轉調,“轉調”的意思是主題序列中每個音符都被加上或減去了同一個整數值。)
 * 3.重複出現的同一主題不能有公共部分。
 *
 * 先轉化成相鄰兩項的差值,然後就是找不可重疊重複子串。
 * 做法就是二分答案LEN
 * 然後根據height值進行分組
 */

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXN=20010;

/*
*suffix array
*倍增演算法  O(n*logn)
*待排序陣列長度為n,放在0~n-1中,在最後面補一個0
*build_sa( ,n+1, );//注意是n+1;
*getHeight(,n);
*例如:
*n   = 8;
*num[]   = { 1, 1, 2, 1, 1, 1, 1, 2, $ };注意num最後一位為0,其他大於0
*rank[]  = { 4, 6, 8, 1, 2, 3, 5, 7, 0 };rank[0~n-1]為有效值,rank[n]必定為0無效值
*sa[]    = { 8, 3, 4, 5, 0, 6, 1, 7, 2 };sa[1~n]為有效值,sa[0]必定為n是無效值
*height[]= { 0, 0, 3, 2, 3, 1, 2, 0, 1 };height[2~n]為有效值
*
*/

int sa[MAXN];//SA陣列,表示將S的n個字尾從小到大排序後把排好序的
             //的字尾的開頭位置順次放入SA中
int t1[MAXN],t2[MAXN],c[MAXN];//求SA陣列需要的中間變數,不需要賦值
int rank[MAXN],height[MAXN];
//待排序的字串放在s陣列中,從s[0]到s[n-1],長度為n,且最大值小於m,
//除s[n-1]外的所有s[i]都大於0,r[n-1]=0
//函式結束以後結果放在sa陣列中
void build_sa(int s[],int n,int m)
{
    int i,j,p,*x=t1,*y=t2;
    //第一輪基數排序,如果s的最大值很大,可改為快速排序
    for(i=0;i<m;i++)c[i]=0;
    for(i=0;i<n;i++)c[x[i]=s[i]]++;
    for(i=1;i<m;i++)c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
    for(j=1;j<=n;j<<=1)
    {
        p=0;
        //直接利用sa陣列排序第二關鍵字
        for(i=n-j;i<n;i++)y[p++]=i;//後面的j個數第二關鍵字為空的最小
        for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        //這樣陣列y儲存的就是按照第二關鍵字排序的結果
        //基數排序第一關鍵字
        for(i=0;i<m;i++)c[i]=0;
        for(i=0;i<n;i++)c[x[y[i]]]++;
        for(i=1;i<m;i++)c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
        //根據sa和x陣列計算新的x陣列
        swap(x,y);
        p=1;x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
        if(p>=n)break;
        m=p;//下次基數排序的最大值
    }
}
void getHeight(int s[],int n)
{
    int i,j,k=0;
    for(i=0;i<=n;i++)rank[sa[i]]=i;
    for(i=0;i<n;i++)
    {
        if(k)k--;
        j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])k++;
        height[rank[i]]=k;
    }
}
int s[MAXN];
bool check(int n,int k)
{
    int Max=sa[1],Min=sa[1];
    for(int i=2;i<=n;i++)
    {
        if(height[i]<k)Max=Min=sa[i];
        else
        {
            if(sa[i]<Min)Min=sa[i];
            if(sa[i]>Max)Max=sa[i];
            if(Max-Min>k)return true;
        }
    }
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    while(scanf("%d",&n)==1 && n)
    {
        for(int i=0;i<n;i++)scanf("%d",&s[i]);
        for(int i=n-1;i>0;i--)s[i]=s[i]-s[i-1]+90;
        n--;//減少一個長度
        for(int i=0;i<n;i++)s[i]=s[i+1];
        s[n]=0;
        build_sa(s,n+1,200);
        getHeight(s,n);
        int ans=-1;
        int l=1,r=n/2;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(check(n,mid))
            {
                ans=mid;
                l=mid+1;
            }
            else r=mid-1;
        }
        if(ans<4)printf("0\n");
        else printf("%d\n",ans+1);
    }
    return 0;
}

 

相關文章