UVALive 7410 && POJ 5583 Kingdom of Black and White (列舉)

_TCgogogo_發表於2016-03-31

Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 869    Accepted Submission(s): 278


Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.
Now N frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.However, an old, evil witch comes, and tells the frogs that she will change the color ofat most one frog and thus the strength of those frogs might change.The frogs wonder the maximum possible strength after the witch finishes her job.
 
Input
First line contains an integerT, which indicates the number of test cases.
Every test case only contains a string with length N, including only 0 (representing
a black frog) and 1 (representing a white frog).

1T50.

for 60% data, 1N1000.

for 100% data, 1N105.

the string only contains 0 and 1.
 
Output
For every test case, you should output "Case #x: y",wherex indicates the case number and counts from 1 and y is the answer.
 
Sample Input
2 000011 0101
 
Sample Output
Case #1: 26 Case #2: 10
 
Source
2015ACM/ICPC亞洲區上海站-重現賽(感謝華東理工)

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=5583

題目大意:給一個0/1串,可以改變其中一個(0改成1 或 1改成0),求連續的0/1串長度平方和的最大值

題目分析:預處理一下原連續的情況,然後列舉改變的點,顯然要變變端點才會更大,要注意一種情況就是連續0跟1個1和連續1跟1個0,特判一下即可

#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const MAX = 1e5 + 10;
char s[MAX];
struct NUM
{
    ll num;
    char ch;
    int l, r;
}d[MAX];

ll f(ll x)
{
    return x * x;
}

int main()
{
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        printf("Case #%d: ", ca);
        scanf("%s", s);
        int len = strlen(s), cnt = 0;
        d[cnt].l = 0;
        d[cnt].num = 1;
        d[cnt].ch = s[0];
        int i;
        for(i = 1; i < len; i++)
        {
            if(s[i] == s[i - 1])
                d[cnt].num ++;
            else
            {
                d[cnt].r = i - 1;
                cnt ++;
                d[cnt].ch = s[i];
                d[cnt].l = i;
                d[cnt].num = 1;
            }
        }
        d[cnt ++].r = i - 1;    
        ll ans = 0;
        for(int i = 0; i < cnt; i++)
            ans += f(d[i].num);
        ll tmp = ans;
        for(int i = 0; i < cnt - 1; i++)
        {
            ll cur = f(d[i].num) + f(d[i + 1].num);
            if(d[i + 1].l == d[i + 1].r && i + 2 < cnt)
            {
                cur += f(d[i + 2].num);
                ans = max(ans, tmp - cur + f(d[i + 2].r - d[i].l + 1));
            }
            else
                ans = max(ans, tmp - cur + f(d[i + 1].l - d[i].l + 1) + f(d[i + 1].r - d[i + 1].l));
        }
        printf("%lld\n", ans);
    }
}


 

相關文章