POJ 3566 Building for UN (無腦構造 水題)

_TCgogogo_發表於2015-10-08


Building for UN
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 1872   Accepted: 832   Special Judge

Description

The United Nations has decided to build a new headquarters in Saint Petersburg, Russia. It will have a form of a rectangular parallelepiped and will consist of several rectangular floors, one on top of another. Each floor is a rectangular grid of the same dimensions, each cell of this grid is an office.

Two offices are considered adjacent if they are located on the same floor and share a common wall, or if one’s floor is the other’s ceiling.

The St. Petersburg building will host n national missions. Each country gets several offices that form a connected set.

Moreover, modern political situation shows that countries might want to form secret coalitions. For that to be possible, each pair of countries must have at least one pair of adjacent offices, so that they can raise the wall or the ceiling they share to perform secret pair-wise negotiations just in case they need to.

You are hired to design an appropriate building for the UN.

Input

The input file consists of a single integer number n (1 ≤ n ≤ 50) — the number of countries that are hosted in the building.

Output

On the first line of the output file write three integer numbers h, w, and l — height, width and length of the building respectively.

h descriptions of floors should follow. Each floor description consists of l lines with w characters on each line. Separate descriptions of adjacent floors with an empty line.

Use capital and small Latin letters to denote offices of different countries. There should be at most 1 000 000 offices in the building. Each office should be occupied by a country. There should be exactly n different countries in the building. In this problem the required building design always exists.

Sample Input

4

Sample Output

2 2 2
AB
CC

zz
zz

Source

Northeastern Europe 2007

題目連結:http://poj.org/problem?id=3566

題目大意:用大寫或小寫字母表示一個國家的所有房間,有n個國家,要求任意兩個國家至少有一個房間相鄰(上下左右前後6個方向),每個國家自己所有的房間要是一個連通集合,求可行的構造方案

題目分析:在紙上畫畫即可

#include <cstdio>
char ans[100] = "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ";

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        printf("2 %d %d\n", n, n);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
                printf("%c", ans[i]);
            printf("\n");
        }
        printf("\n");
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
                printf("%c", ans[j]);
            printf("\n");
        }
    }
}


相關文章