lightoj 1030 Discovering Gold (基礎概率dp)
Time Limit: 2000MS | Memory Limit: 32768KB | 64bit IO Format: %lld & %llu |
Description
You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.
Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.
Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.
Sample Input
3
1
101
2
10 3
3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15
題目大意:一條線上n個點,每個點有不同數量的金子,每次投骰子1-6,投到幾前進幾步並得到對應點上的金子,如果點數超過n則繼續投,直到到n為止,求得到金子數量的期望值
題目分析:很基礎的概率dp,設dp[i]為從i到n所能得到的金子的期望,顯然dp[n] = val[n],然後從後往前遞推,dp[i - 1] += Σdp[i] / 6,但是注意有可能加6會超過n,所以遞推式應該為dp[i - 1] += Σj (1-6) dp[i] / min(6, n - i)
#include <cstdio>
#include <algorithm>
using namespace std;
int const MAX = 105;
double dp[MAX];
int main()
{
int T;
scanf("%d", &T);
for(int ca = 1; ca <= T; ca++)
{
int n;
scanf("%d", &n);
for(int i = 1; i <= n; i++)
scanf("%lf", &dp[i]);
for(int i = n - 1; i >= 1; i--)
for(int j = 1; j <= 6; j++)
dp[i] += dp[i + j] / (1.0 * min(6, n - i));
printf("Case %d: %.8f\n", ca, dp[1]);
}
}
相關文章
- 概率DP入門題
- Lightoj 1021 Painful Bases (狀壓dp 有趣)AI
- 概率DP總結 by kuangbin
- HDU 3853 LOOPS(概率dp)OOP
- SGU 495 Kids and Prizes:期望dp / 概率dp / 推公式公式
- codeforces 148 D 概率dp
- POJ 3744 概率dp+矩陣矩陣
- 狀壓DP基礎入門
- codeforces 148 D Bag of mice(概率dp)
- 【基礎dp】HDU 1260 Tickets
- Codeforces 148D Bag of mice (概率dp)
- 機器學習數學複習 - 1.概率論基礎機器學習
- AI數學基礎之:概率和上帝視角AI
- 技術基礎 | 捨棄”讀修復概率”特性
- 圖解AI數學基礎 | 概率與統計圖解AI
- HDU 5326 Work (基礎樹形dp)
- 【演算法學習筆記】概率與期望DP演算法筆記
- 專題十二 基礎DP1 題集
- 【基礎dp】HDU 1176 免費餡餅
- POJ 1664 放蘋果 (基礎組合dp)蘋果
- HDU 4326Game(比較難理解的概率dp)GAM
- 動態規劃之經典數學期望和概率DP動態規劃
- POJ3744 Scout YYF I (概率DP + 矩陣優化)矩陣優化
- 關於一些基礎的dp——硬幣的那些事(dp的基本引入)
- 【基礎dp】HDU 1257 最少攔截系統
- UA MATH563 概率論的數學基礎 中心極限定理23 概率測度族的緊性H5
- lightoj 1031 - Easy Game 【區間dp】360 2017筆試程式設計題3GAM筆試程式設計
- 「暑期訓練」「基礎DP」 Common Subsequence (POJ-1458)
- POJ 1947 Rebuilding Roads(基礎的樹形dp)Rebuild
- Codeforces 148D Bag of mice:概率dp 記憶化搜尋
- Codeforces 351B Jeff and Furik:概率 + 逆序對【結論題 or dp】
- UVA 11427 Expect the Expected (概率dp+推公式求期望 詳解)公式
- 2014鞍山網路賽 E題||hdu 5001 概率dp
- BZOJ 1030: [JSOI2007]文字生成器 DP,AC自動機JS
- 1030顯示卡怎麼樣 1030顯示卡能玩什麼遊戲遊戲
- 「暑期訓練」「基礎DP」免費餡餅(HDU-1176)
- How to create the Gold gold using RGB color values All In OneGo
- 人工智慧必備數學基礎:概率論與數理統計(1)人工智慧