HDU 3038 How Many Answers Are Wrong (帶權並查集)

_TCgogogo_發表於2015-09-24


How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4120    Accepted Submission(s): 1577

Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b
FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.
Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.
The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.
However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.
What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.
But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 
Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.
Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.
You can assume that any sum of subsequence is fit in 32-bit integer.
 
Output
A single line with a integer denotes how many answers are wrong.
 
Sample Input
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 
Sample Output
1
 
Source
 
題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=3038

題目大意:n個數字,m個命題,a b s,表示從a到b的閉區間的數值和為s,求從第一個命題開始有幾個與之前的相矛盾,不矛盾的則認為是正確的命題

題目分析:s = Σ(1,b) - Σ(1,a-1),因此利用帶權並查集,把數字小的當作根,計算偏移量,如果根相同,偏移量不為s,則表示矛盾,根不相同時合併,合併是要改變偏移量
如果fa < fb,則fa做根,w[x]表示x對根的偏移量,都是從大數字到小數字的
w[a] = a -> fa,w[b] = b -> fb,s = b -> a,fb -> fa = -fb -> b + b -> a + a -> fa = w[a] + s - w[b],fa > fb時同理

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 2e5 + 5;
int fa[MAX], w[MAX];
int n, m;

void UF_set()
{
    for(int i = 0; i <= n; i++)
    {
        fa[i] = i;
        w[i] = 0;
    }
}

int Find(int x)
{
    if(x == fa[x])
        return x;
    int tmp = fa[x];
    fa[x] = Find(fa[x]);
    w[x] += w[tmp];
    return fa[x];
}

bool Union(int a, int b, int x)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 < r2)
    {
        fa[r2] = r1;
        w[r2] = w[a] - w[b] + x;
    }
    else if(r1 > r2)
    {
        fa[r1] = r2;
        w[r1] = w[b] - w[a] - x;
    }
    else if(r1 == r2 && w[b] - w[a] != x)
        return true;
    return false;
}

int main()
{
    while(scanf("%d %d", &n, &m) != EOF)
    {
        UF_set();
        int cnt = 0;
        while(m --)
        {
            int a, b, x;
            scanf("%d %d %d", &a, &b, &x);
            if(Union(a - 1, b, x))
                cnt ++;
        }
        printf("%d\n", cnt);
    }
}




相關文章