HDU 5444 Elven Postman (排序二叉樹 訪問路徑 陣列&&連結串列實現)
Elven Postman
Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 531 Accepted Submission(s): 292
Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something
about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.
So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.
Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.
Your task is to determine how to reach a certain room given the sequence written on the root.
For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.
So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.
Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.
Your task is to determine how to reach a certain room given the sequence written on the root.
For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.
Input
First you are given an integer
T(T≤10)
indicating the number of test cases.
For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.
On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.
For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.
On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.
Output
For each query, output a sequence of move (E
or W)
the postman needs to make to deliver the mail. For that
E
means that the postman should move up the eastern branch and
W
the western one. If the destination is on the root, just output a blank line would suffice.
Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
Sample Input
2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1
Sample Output
E
WE
EEEEE
Source
2015 ACM/ICPC Asia Regional Changchun Online
題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=5444
題目大意:先建立一棵排序二叉樹,然後輸出查詢結點的路徑
題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=5444
題目大意:先建立一棵排序二叉樹,然後輸出查詢結點的路徑
題目分析:基礎資料結構,這裡用陣列和連結串列兩種方式實現,其實本質相同
陣列:
#include <cstdio>
#include <cstring>
int const MAX = 1e3 + 5;
int n, m, a[MAX];
struct Tree
{
int lson, rson, val;
}t[MAX];
void Insert(int rt, int val, int idx)
{
if(t[rt].val < val)
{
if(t[rt].rson == -1)
{
t[rt].rson = idx;
t[idx].val = val;
}
else
Insert(t[rt].rson, val, idx);
}
else if(t[rt].val > val)
{
if(t[rt].lson == -1)
{
t[rt].lson = idx;
t[idx].val = val;
}
else
Insert(t[rt].lson, val, idx);
}
}
void DFS(int rt, int val)
{
if(t[rt].val < val)
{
printf("W");
if(t[rt].rson != -1)
DFS(t[rt].rson, val);
}
else if(t[rt].val > val)
{
printf("E");
if(t[rt].lson != -1)
DFS(t[rt].lson, val);
}
else
return;
}
int main()
{
int T;
scanf("%d", &T);
while(T--)
{
memset(t, -1, sizeof(t));
scanf("%d", &n);
for(int i = 0; i < n; i++)
scanf("%d", &a[i]);
t[0].val = a[0];
for(int i = 1; i < n; i++)
Insert(0, a[i], i);
scanf("%d", &m);
while(m --)
{
int tmp;
scanf("%d", &tmp);
DFS(0, tmp);
printf("\n");
}
}
}
連結串列:
連結串列的時候應當要delete樹的,但是資料量不大,可以不釋放
#include <cstdio>
#include <cstring>
int const MAX = 1e3 + 5;
int n, m, val[MAX];
struct TREE
{
TREE *lson, *rson;
int val;
TREE()
{
lson = NULL;
rson = NULL;
val = 0;
}
};
void Insert(TREE *rt, int val)
{
if(val > rt -> val)
{
if(rt -> rson == NULL)
{
rt -> rson = new TREE();
rt -> rson -> val = val;
}
else
Insert(rt -> rson, val);
}
if(val < rt -> val)
{
if(rt -> lson == NULL)
{
rt -> lson = new TREE();
rt -> lson -> val = val;
}
else
Insert(rt -> lson, val);
}
}
void DFS(TREE *rt, int tmp)
{
if(rt == NULL)
return;
if(tmp > rt -> val)
{
printf("W");
DFS(rt -> rson, tmp);
}
else if(tmp < rt -> val)
{
printf("E");
DFS(rt -> lson, tmp);
}
else
return;
}
void Del(TREE *rt)
{
if(rt == NULL)
return;
Del(rt -> lson);
Del(rt -> rson);
delete rt;
}
int main()
{
int T;
scanf("%d", &T);
while(T --)
{
TREE *root = new TREE();
scanf("%d", &n);
for(int i = 0; i < n; i++)
scanf("%d", &val[i]);
root -> val = val[0];
for(int i = 1; i < n; i++)
Insert(root, val[i]);
scanf("%d", &m);
while(m --)
{
int tmp;
scanf("%d", &tmp);
DFS(root, tmp);
printf("\n");
}
Del(root);
}
}
相關文章
- (樹)根據排序陣列或者排序連結串列重新構建BST樹排序陣列
- 歸併排序:陣列和連結串列的多種實現排序陣列
- 排序演算法集:冒泡、插入、希爾、快速(陣列實現、連結串列實現)排序演算法陣列
- (連結串列)連結串列的排序問題排序
- 將二叉排序樹BST轉換成排序的雙向連結串列排序
- 陣列和連結串列陣列
- 陣列與連結串列陣列
- 資料結構--單連結串列(通過陣列實現)資料結構陣列
- 二叉樹展開為連結串列二叉樹
- 資料結構之連結串列與陣列(1):陣列和連結串列的簡介資料結構陣列
- 【連結串列問題】打卡10:將搜尋二叉樹轉換成雙向連結串列二叉樹
- 微軟面試題,將二叉排序樹轉換成雙向連結串列微軟面試題排序
- hdu 3874 樹狀陣列陣列
- 可變陣列——連結串列前言陣列
- 陣列模擬單連結串列陣列
- Android技能樹 — 陣列,連結串列,雜湊表基礎小結Android陣列
- 連結串列-單連結串列實現
- 資料結構--陣列、單向連結串列、雙向連結串列資料結構陣列
- 利用遞迴實現連結串列的排序(歸併排序)遞迴排序
- 二叉排序樹的實現排序
- 資料結構-棧(通過陣列和單向連結串列實現)資料結構陣列
- 單連結串列的排序問題排序
- 線性結構 陣列與連結串列陣列
- hdu 5147 樹狀陣列陣列
- 二叉連結串列儲存結構、二叉樹相關操作二叉樹
- 陣列和連結串列的區別陣列
- 用連結串列實現佇列的功能佇列
- 完全二叉樹實現優先佇列與堆排序二叉樹佇列排序
- 聊聊陣列與連結串列,棧與佇列陣列佇列
- 《演算法圖解》NOTE 2 陣列、連結串列及選擇排序演算法圖解陣列排序
- 陣列排序的實現陣列排序
- 資料結構之陣列和連結串列資料結構陣列
- js實現完全排序二叉樹、二叉搜尋樹JS排序二叉樹
- 資料結構之連結串列與陣列(2):單向連結串列上的簡單操作問題資料結構陣列
- 面試-陣列和連結串列的區別面試陣列
- 刪除陣列中的元素(連結串列)陣列
- day1-陣列和連結串列陣列
- 鏈式佇列—用連結串列來實現佇列佇列