POJ 1523 SPF (無向圖求割點 tarjan演算法)
SPF
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 7147 | Accepted: 3262 |
Description
Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on
the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant;
1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0
1 2
2 3
3 4
4 5
5 1
0
1 2
2 3
3 4
4 6
6 3
2 5
5 1
0
0
Sample Output
Network #1
SPF node 3 leaves 2 subnets
Network #2
No SPF nodes
Network #3
SPF node 2 leaves 2 subnets
SPF node 3 leaves 2 subnets
Source
題目連結:http://poj.org/problem?id=1523
題目大意:無向圖求割點和去除割點後連通分量的個數
題目分析:裸題,Tarjan演算法直接搞
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 1005;
bool vis[MAX];
int head[MAX];
int low[MAX], dfn[MAX], subnet[MAX];
int cnt, ma, tmpdfn, son;
struct EGDE
{
int v, next;
}e[MAX];
void Add(int u, int v)
{
e[cnt].v = v;
e[cnt].next = head[u];
head[u] = cnt ++;
}
void Init()
{
ma = 0;
son = 0;
cnt = 0;
tmpdfn = 1;
memset(head, -1, sizeof(head));
memset(vis, false, sizeof(vis));
memset(low, 0, sizeof(low));
memset(dfn, 0, sizeof(dfn));
memset(subnet, 0, sizeof(subnet));
}
void DFS(int u)
{
vis[u] = true;
for(int i = head[u]; i != -1; i = e[i].next)
{
int v = e[i].v;
if(!vis[v])
{
tmpdfn ++;
low[v] = tmpdfn;
dfn[v] = tmpdfn;
DFS(v);
low[u] = min(low[u], low[v]);
if(low[v] >= dfn[u])
(u == 1) ? son ++ : subnet[u] ++;
}
else
low[u] = min(low[u], dfn[v]);
}
}
int main()
{
int u, v, ca = 1;
while(scanf("%d", &u) != EOF && u)
{
Init();
scanf("%d", &v);
Add(u, v);
Add(v, u);
ma = max(ma, max(u, v));
while(scanf("%d", &u) != EOF && u)
{
scanf("%d", &v);
Add(u, v);
Add(v, u);
ma = max(ma, max(u, v));
}
DFS(1);
if(son > 1)
subnet[1] = son - 1;
printf("Network #%d\n", ca ++);
bool flag = false;
for(int i = 1; i <= ma; i++)
{
if(subnet[i])
{
flag = true;
printf(" SPF node %d leaves %d subnets\n", i, subnet[i] + 1);
}
}
if(!flag)
printf(" No SPF nodes\n");
printf("\n");
}
}
相關文章
- POJ 1523-SPF(Tarjan演算法-關節點)演算法
- tarjan演算法求scc & 縮點演算法
- Tarjan 求有向圖的強連通分量
- POJ 1734 Sightseeing trip Floyd求無向圖最小環
- POJ 3592 Instantaneous Transference 圖論演算法tarjan+spfa圖論演算法
- POJ 2186 Popular Cows(強連通分量縮點,Tarjan演算法)演算法
- Tarjan演算法_縮點演算法
- 演算法學習之路|有向無環圖(DAG)求最長路演算法
- POJ 1330 LCA最近公共祖先 離線tarjan演算法演算法
- 連通圖與Tarjan演算法演算法
- POJ 3469-Dual Core CPU(Dinic 最大流/最小割演算法)演算法
- Tarjan演算法求強連通分量總結演算法
- POJ 2914-Minimum Cut(Stoer_Wagner最小割演算法)演算法
- 圖論複習之強連通分量以及縮點—Tarjan演算法圖論演算法
- 圖論——強連通分量(Tarjan演算法)圖論演算法
- POJ 3308 Paratroopers 最小割、最大流OOP
- 強連通分量及縮點tarjan演算法解析演算法
- 連通圖演算法詳解之① :Tarjan 和 Kosaraju 演算法演算法
- 無向圖最小割問題取得新突破,谷歌研究獲SODA 2024最佳論文獎谷歌
- 嗅探器(割點)
- tarjan—演算法的神(一)演算法
- 「學習筆記」tarjan 求最近公共祖先筆記
- 圖之強連通、強連通圖、強連通分量 Tarjan演算法演算法
- 圖論-有向圖縮點圖論
- 尋找圖的強連通分量:tarjan演算法簡單理解演算法
- 強連通分量(Tarjan演算法)演算法
- Tarjan 演算法學習筆記演算法筆記
- 【演算法學習】tarjan 強連通、點雙、邊雙及其縮點 重磅來襲!!!!演算法
- 【筆記/模板】割點和橋筆記
- POJ 基本演算法演算法
- OSPF:使用SPF演算法的路由傳播 (轉)演算法路由
- Tarjan演算法(強連通分量分解)演算法
- POJ 1039-Pipe(計算幾何-線段相交、求交點)
- 強連通------tarjan演算法詳解及與縮點聯合運用演算法
- 強連通分量與縮點(Tarjan演算法)(洛谷P3387)演算法
- 【模板】tarjan 強連通分量縮點
- 淺談演算法和資料結構(12):無向圖相關演算法基礎演算法資料結構
- 待補 重要思考:求給無向圖定向使得其變為DAG的方案數