POJ 3468 A Simple Problem with Integers (線段樹 區間更新)
A Simple Problem with Integers
Time Limit: 5000MS | Memory Limit: 131072K | |
Total Submissions: 75143 | Accepted: 23146 | |
Case Time Limit: 2000MS |
Description
You have N integers, A1,A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N andQ. 1 ≤
N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... ,
AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa,
Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.
Source
POJ Monthly--2007.11.25, Yang Yi
題目連結:http://poj.org/problem?id=3468
題目大意:給一串數,C操作對區間累加值,Q操作查詢區間和
題目分析:裸的線段樹區間更新問題
題目連結:http://poj.org/problem?id=3468
題目大意:給一串數,C操作對區間累加值,Q操作查詢區間和
題目分析:裸的線段樹區間更新問題
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
int const MAX = 1e5 + 5;
ll sum[MAX << 2], add[MAX << 2];
void PushUp(int rt)
{
sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void PushDown(int ln, int rn, int rt)
{
if(add[rt])
{
sum[rt << 1] += (ll)ln * add[rt];
sum[rt << 1 | 1] += (ll)rn * add[rt];
add[rt << 1] += add[rt];
add[rt << 1 | 1] += add[rt];
add[rt] = 0;
}
return;
}
void Build(int l, int r, int rt)
{
add[rt] = 0;
if(l == r)
{
scanf("%lld", &sum[rt]);
return;
}
int mid = (l + r) >> 1;
Build(lson);
Build(rson);
PushUp(rt);
return;
}
void Update(int L, int R, int c, int l, int r, int rt)
{
if(L <= l && r <= R)
{
sum[rt] += (r - l + 1) * c;
add[rt] += c;
return;
}
int mid = (l + r) >> 1;
PushDown(mid - l + 1, r - mid, rt);
if(L <= mid)
Update(L, R, c, lson);
if(R > mid)
Update(L, R, c, rson);
PushUp(rt);
return;
}
ll Query(int L, int R, int l, int r, int rt)
{
if(L <= l && r <= R)
return sum[rt];
int mid = (l + r) >> 1;
PushDown(mid - l + 1, r - mid, rt);
ll ans = 0;
if(L <= mid)
ans += Query(L, R, lson);
if(R > mid)
ans += Query(L, R, rson);
return ans;
}
int main()
{
int n, q;
scanf("%d %d", &n, &q);
Build(1, n, 1);
while(q --)
{
char s[2];
scanf("%s", s);
if(s[0] == 'Q')
{
int l, r;
scanf("%d %d", &l, &r);
printf("%lld\n", Query(l, r, 1, n, 1));
}
else
{
int l, r, c;
scanf("%d %d %d", &l, &r, &c);
Update(l, r, c, 1, n, 1);
}
}
}
相關文章
- POJ 3468-A Simple Problem with Integers(區間更新線段樹)
- POJ 3468 A Simple Problem with Integers(線段樹區間操作)
- POJ 3468 A Simple Problem with Integers (線段樹 區間共加)
- (poj3468)A Simple Problem with Integers(區間更新)
- 【poj3468】A Simple Problem with Integers
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- bzoj3212: Pku3468 A Simple Problem with Integers(線段樹)
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)
- POJ 2528 Mayor's posters (線段樹區間更新 + 離散化)
- NC17383 A Simple Problem with Integers
- hihocoder 1078 線段樹的區間修改 (線段樹 區間更新 模板)
- poj 3468 區間更新 整個區間加一個數和區間求和操作
- HDU 1698 Just a Hook (線段樹區間更新)Hook
- Codeforces 52C (線段樹區間更新)
- POJ 2777-Count Color(線段樹-區間染色查詢)
- POJ 3264-Balanced Lineup詳解(線段樹區間求值)
- poj 3237 樹鏈剖分(區間更新,區間查詢)
- Codeforces 272C Dima and Staircase (線段樹區間更新 或 線性掃)AI
- 線段樹(3)——區間操作疊加
- 芻議線段樹 2 (區間修改,區間查詢)
- 線段樹維護區間等差數列
- HDU 1754 I Hate It (線段樹 區間最值)
- Java 演算法-區間求和I(線段樹)Java演算法
- 區間k小值(可持久化線段樹)持久化
- POJ 1195-Mobile phones(二維樹狀陣列-區間更新區間查詢)陣列
- POJ 2991 Crane(線段樹+計算幾何)
- hdu 2665 可持久化線段樹求區間第K大值(函式式線段樹||主席樹)持久化函式
- 1082 線段樹練習 3 區間查詢與區間修改
- POJ 2777 Count Color 線段樹入門題
- 區間演算法題用線段樹可以秒解?演算法
- POJ 2828 Buy Tickets 線段樹入門(建樹稍微有點抽象)抽象
- A - Yet Another Two Integers Problem ACMACM
- HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】Hook
- 線段樹學習筆記(更新中)筆記
- POJ 2886 Who Gets the Most Candies?(線段樹+反素數)
- POJ 2891 Strange Way to Express IntegersExpress
- 【樹狀陣列 區間更新區間查詢】code陣列