HDU 1698 Just a Hook (線段樹區間更新)

_TCgogogo_發表於2015-07-30


Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 21856    Accepted Submission(s): 10963

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
1 10 2 1 5 2 5 9 3
 
Sample Output
Case 1: The total value of the hook is 24.
 
Source
2008 “Sunline Cup” National Invitational Contest

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1698

題目大意:開始區間1-n值都為1,x y z表示把區間[x, y]的值都改成z,最後輸出區間和

題目分析:基礎的線段樹區間更新
#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
using namespace std;
int const MAX = 1e5 + 5;
int sum[MAX << 2], lazy[MAX << 2];
int n, q;

void PushUp(int rt)
{
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void PushDown(int ln, int rn, int rt)
{
	if(lazy[rt])
	{
		sum[rt << 1] = lazy[rt] * ln;
		sum[rt << 1 | 1] = lazy[rt] * rn;
		lazy[rt << 1] = lazy[rt];
		lazy[rt << 1 | 1] = lazy[rt];
		lazy[rt] = 0;
	}
	return;
}

void Build(int l, int r, int rt)
{
	lazy[rt] = 0;
	if(l == r)
	{
		sum[rt] = 1;
		return;
	}
	int mid = (l + r) >> 1;
	Build(lson);
	Build(rson);
	PushUp(rt);
}

void Update(int L, int R, int c, int l, int r, int rt)
{
	if(L <= l && r <= R)
	{
		sum[rt] = (r - l + 1) * c;
		lazy[rt] = c;
		return;
	}
	int mid = (l + r) >> 1;
	PushDown(mid - l + 1, r - mid, rt);
	if(L <= mid)
		Update(L, R, c, lson);
	if(mid < R)
		Update(L, R, c, rson);
	PushUp(rt);
	return;
}

int main()
{
	int T;
	scanf("%d", &T);
	for(int ca = 1; ca <= T; ca++)
	{
		scanf("%d %d", &n, &q);
		Build(1, n, 1);
		while(q --)
		{
			int l, r, c;
			scanf("%d %d %d", &l, &r, &c);
			Update(l, r, c, 1, n, 1);
		}
		printf("Case %d: The total value of the hook is %d.\n", ca, sum[1]);
	}
}




相關文章