HDU 1394 Minimum Inversion Number (樹狀陣列求逆序數)
Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13942 Accepted Submission(s): 8514
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to
n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
Author
CHEN, Gaoli
Source
題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1394
題目大意:給一組數,每次可以把開頭的數拿到末尾,問這樣組成的序列中逆序數最小的逆序數值
題目分析:先用樹狀陣列求逆序數,每次交換後的逆序數值可以直接算出來,因為是一個0~n-1的排列,所以把第一個數(設為fir)拿到最後先當作減少了fir個逆序數,又這組排列中肯定有n-fir-1個數是大於fir的,再把它們加上,所以逆序數變化的個數為-fir+n-fir-1
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 5005;
int c[MAX], a[MAX], n;
int lowbit(int x)
{
return x & (-x);
}
void Add(int x)
{
for(int i = x; i <= n; i += lowbit(i))
c[i] ++;
}
int Sum(int x)
{
int res = 0;
for(int i = x; i > 0; i -= lowbit(i))
res += c[i];
return res;
}
int main()
{
while(scanf("%d", &n) != EOF)
{
memset(c, 0, sizeof(c));
int ini = 0;
for(int i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
a[i] ++;
ini += Sum(n) - Sum(a[i]);
Add(a[i]);
}
int mi = ini;
for(int i = 1; i <= n; i++)
{
ini += (-(a[i] - 1) + n - (a[i] - 1) - 1);
mi = min(mi, ini);
}
printf("%d\n", mi);
}
}
相關文章
- hdu 1394 Minimum Inversion Number 【線段樹查詢】
- HDU2689 Sort it (樹狀陣列求逆序數)陣列
- HDU 2689 Sort it【樹狀陣列求逆序對】陣列
- HDU 4911 Inversion(歸併排序求逆序數)排序
- POJ 2299-Ultra-QuickSort(樹狀陣列求逆序數)UI陣列
- 樹狀陣列和逆序對陣列
- hdu 3874 樹狀陣列陣列
- POJ 3067-Japan(樹狀陣列-逆序數)陣列
- hdu 5147 樹狀陣列陣列
- hdu4417 樹狀陣列(求指定區間比指定數小的數的個數)陣列
- hdu 4836 The Query on the Tree(線段樹or樹狀陣列)陣列
- HDU5419Victor and Toys(樹狀陣列+數學期望)陣列
- 求區間不同數的個數【樹狀陣列求解】陣列
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- hdu4325 樹狀陣列+離散化陣列
- hdu 4368 樹狀陣列 離線維護陣列
- HDU 1166 敵兵佈陣 (樹狀陣列)陣列
- HDU 1166 敵兵佈陣(樹狀陣列)陣列
- HDU 1541 & POJ 2352 Stars (樹狀陣列)陣列
- HDU4843Wow! Such Sequence!(樹狀陣列寫法)陣列
- 樹狀陣列陣列
- 【陣列】1394. 找出陣列中的幸運數(簡單)陣列
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- 解析樹狀陣列陣列
- 【樹狀陣列 求比其小的個數】poj 2353 Stars陣列
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- LeetCode C++ 劍指 Offer 51. 陣列中的逆序對【歸併排序/樹狀陣列/線段樹】LeetCodeC++陣列排序
- D 區間求和 [數學 樹狀陣列]陣列
- 陣列元素逆序陣列
- HDU 5862 Counting Intersections(樹狀陣列+掃描線+離散化)陣列
- HDU5147 Sequence II(樹狀陣列+字首和+字尾和)陣列
- HDU4991 Ordered Subsequence (dp+樹狀陣列+離散化)陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- poj 2481 樹狀陣列陣列
- 二維樹狀陣列陣列
- 【樹狀陣列 單點修改,區間求值】hdu 1166 敵兵佈陣陣列
- SPOJ DQUERY (離線數狀陣列||線上主席樹)陣列