C語言實驗——分割整數 (sdut oj)

SwordsMan98發表於2017-01-29


C語言實驗——分割整數

Time Limit: 1000MS Memory Limit: 65536KB



Problem Description

從鍵盤輸入一個長整數(不超過10位),從高位開始逐位分割並輸出。


Input

正整數n,不含前導零。


Output

分割的整數序列,各整數之間用空格格開。
注意,最後一個數字後面沒有空格!


Example Input

654321


Example Output

6 5 4 3 2 1

Hint

Author








參考程式碼


#include<stdio.h>
int main()
{
    int a[10];
    long n;
    int i;
    scanf("%d",&n);
    for(i = 0; i < 10; i++)
    {
        a[i] = n % 10;
        n = n / 10;
        if(n == 0)
            break;
    }
    n = i;
    for(i = n; i >= 0; i--)
    {
        if(i == 0)
            printf("%d\n",a[i]);
        else
            printf("%d ",a[i]);
    }
    return 0;
}


相關文章