C語言實驗——整數位 (sdut oj)

SwordsMan98發表於2017-01-29


C語言實驗——整數位

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

輸入一個不多於5位的正整數,要求: 
(1)求出它是幾位數; 
(2)分別輸出每一位數字; 
(3)按逆序輸出各位數字。


Input

輸入一個不多於5位的正整數。


Output

輸出資料有3行,第一行為正整數位數,第二行為各位數字,第三行為逆序的各位數字。


Example Input

123


Example Output

3
1 2 3
3 2 1


Hint

Author

crq






參考程式碼


#include<stdio.h>
int main()
{
    int num;
    int g[5] = {0};
    int i;
    int x = 1;
    scanf("%d",&num);
    for(i = 4; i >= 0; i--)
    {
        g[i] = num / x % 10;
        x = x * 10;
    }
    for(i = 0; i < 5; i++)
    {
        if(g[i] != 0)
            break;
    }
    x = 5 - i;
    printf("%d\n",x);
    for(i = 5 - x; i < 5; i++)
    {
        if(i == 5 - x)
            printf("%d",g[i]);
        else
            printf(" %d",g[i]);
    }
    printf("\n");
    for(i = 4; i >= 5 - x; i--)
    {
        if(i == 4)
            printf("%d",g[i]);
        else
            printf(" %d",g[i]);
    }
    return 0;
}


相關文章