計算題 (sdut oj)

SwordsMan98發表於2017-01-27


計算題

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

一個簡單的計算,你需要計算f(m,n),其定義如下:
當m=1時,f(m,n)=n;
當n=1時,f(m,n)=m;
當m>1,n>1時,f(m,n)= f(m-1,n)+ f(m,n-1)


Input

第一行包含一個整數T(1<=T<=100),表示下面的資料組數。
以下T行,其中每組資料有兩個整數m,n(1<=m,n<=2000),中間用空格隔開。


Output

對每組輸入資料,你需要計算出f(m,n),並輸出。每個結果佔一行。


Example Input

2
1 1
2 3


Example Output

1
7


Hint

Author








參考程式碼


#include<stdio.h>
int f(int m,int n)
{
    int y;
    if(m == 1)
    {
        y = n;
    }
    else if(n == 1)
    {
        y = m;
    }
    else
    {
        y = f(m - 1, n) + f(m, n - 1);
    }
    return y;
}
int main()
{
    int t;
    int m,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        printf("%d\n",f(m,n));
    }
    return 0;
}


相關文章