C/C++經典程式訓練2---斐波那契數列 (sdut oj)

SwordsMan98發表於2017-01-27


C/C++經典程式訓練2---斐波那契數列

Time Limit: 1000MS Memory Limit: 65536KB



Problem Description

編寫計算斐波那契(Fibonacci)數列的第n項函式fib(n)(n<40)。
數列:
f1=f2==1; 
fn=fn-1+fn-2(n>=3)。


Input

輸入整數n的值。


Output

輸出fib(n)的值。


Example Input

7


Example Output

13

Hint

 

Author






參考程式碼


#include<stdio.h>
int fib(int n)
{
    int y;
    if(n == 1 || n == 2)
    {
        y = 1;
    }
    else
    {
        y = fib(n - 1) + fib(n - 2);
    }
    return y;
}
int main()
{
    int n;
    scanf("%d",&n);
    printf("%d\n",fib(n));
    return 0;
}


相關文章