C/C++經典程式訓練5---圖形列印問題 (sdut oj)

SwordsMan98發表於2017-01-25


C/C++經典程式訓練5---圖形列印問題

Time Limit: 1000MS Memory Limit: 4096KB



Problem Description

圖形的規則如下 ,要求輸入n的值,按照圖形的列印規則列印出相關的圖形:


Input

輸入整數n。


Output

按圖形的規律列印出相關的圖形。


Example Input

4


Example Output

   +
  +*+
 +***+
+*****+
 +***+
  +*+
   +

Hint

Author








參考程式碼



#include<stdio.h>
int main()
{
    int n;
    int i;
    int temp;
    scanf("%d",&n);
    for(i = 1; i <= n; i++)
    {
        for(temp = i; temp < n; temp++)
        {
            printf(" ");
        }
        printf("+");
        for(temp = i; temp > 1; temp--)
        {
            printf("*");
        }
        for(temp = i - 1; temp > 1; temp--)
        {
            printf("*");
        }
        if(i != 1)
            printf("+");
        printf("\n");
    }
    for(i = n - 1; i > 0; i--)
    {
        for(temp = i; temp < n; temp++)
        {
            printf(" ");
        }
        printf("+");
        for(temp = i; temp > 1; temp--)
        {
            printf("*");
        }
        for(temp = i - 1; temp > 1; temp--)
        {
            printf("*");
        }
        if(i != 1)
            printf("+");
        printf("\n");
    }
    return 0;
}



相關文章