HDU2588GCD(尤拉函式)
GCD
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 972 Accepted Submission(s): 437
Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260
若X與n存在大於m的最大公約數,設d=(x,n);
則X=q*d,n=p*d; 並且 (p,q)=1;
我們可以列舉公約數,由尤拉函式的定義可知 phi(p)即為所求
程式碼如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int phi(int n)
{
int rea=n;
for(int i=2;i*i<=n;i++){
if(n%i==0){
rea=rea/i*(i-1);
while(n%i==0)
n/=i;
}
}
if(n!=1)
rea=rea/n*(n-1);
return rea;
}
int main()
{
int cas,n,m;
cin>>cas;
while(cas--){
cin>>n>>m;
int ans=0;
for(int i=1;i*i<=n;i++){
if(n%i==0){//i或者n/i為公約數的情況
if(i>=m)//i為公約數 n/i為係數
ans+=phi(n/i);
if(i*i!=n&&n/i>=m)//i!=n/i時並且 n/i為公約數的情況
ans+=phi(i);
}
}
cout<<ans<<endl;
}
return 0;
}
相關文章
- 尤拉函式φ函式
- 4939 尤拉函式函式
- 尤拉函式入門函式
- 尤拉函式詳解函式
- poj 2478 尤拉函式函式
- 淺談尤拉函式函式
- 尤拉函式性質和模版函式
- 轉載:尤拉函式知識點總結及程式碼模板及尤拉函式表函式
- Note -「因數的尤拉函式求和」函式
- bzoj2818: Gcd(尤拉函式)GC函式
- POJ 2478-Farey Sequence(尤拉函式)函式
- B.日記和尤拉函式函式
- 尤拉計劃512題(冪的尤拉總計函式和)函式
- POJ 2048 Longge's problem (尤拉函式 積性函式)函式
- HDU 4002Find the maximum(尤拉函式)函式
- POJ 2407-Relatives-尤拉函式函式
- [藍橋杯][演算法提高VIP]尤拉函式演算法函式
- HDU 1695-GCD(容斥原理+尤拉函式)GC函式
- HDU 3501 Calculation 2 (尤拉函式應用)函式
- 51nod1262 扔球(尤拉函式)函式
- 尤拉函式、整除分塊和擴充套件歐幾里得函式套件
- §3. 復變數的指數函式·尤拉公式變數函式公式
- 尤拉計劃533題:卡邁克爾函式函式
- POJ2487Farey Sequence(尤拉函式&&法雷級數)函式
- HDU3501 Calculation 2(尤拉函式推廣)函式
- 51nod1040 最大公約數之和 (尤拉函式 )函式
- BZOJ 2818 Gcd (莫比烏斯反演 或 尤拉函式)GC函式
- 紫書 例題 10-27 UVa 10214(尤拉函式)函式
- bzoj2190: [SDOI2008]儀仗隊(尤拉函式)函式
- FZU 1969 && UVA 11426 GCD Extreme (尤拉函式 或 莫比烏斯反演)GCREM函式
- 尤拉公式——真正的宇宙第一公式公式
- 數論線性篩總結 (素數篩,尤拉函式篩,莫比烏斯函式篩,前n個數的約數個數篩)函式
- MySQL函式大全(字串函式,數學函式,日期函式,系統級函式,聚合函式)MySql函式字串
- P2303 [SDOI2012] Longge 的問題(尤拉函式,推式子)函式
- HDU 4279 2012網路賽Number(數論 尤拉函式結論約數個數)函式
- Oracle 函式大全(字串函式,數學函式,日期函式,邏輯運算函式,其他函式)Oracle函式字串
- 【函式式 Swift】函式式思想函式Swift
- 尤拉篩