HDU2588GCD(尤拉函式)

bigbigship發表於2014-07-24

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 972    Accepted Submission(s): 437


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
3 1 1 10 2 10000 72
 

Sample Output
1 6 260
若X與n存在大於m的最大公約數,設d=(x,n);
則X=q*d,n=p*d; 並且 (p,q)=1;
我們可以列舉公約數,由尤拉函式的定義可知 phi(p)即為所求
程式碼如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int phi(int n)
{
    int rea=n;
    for(int i=2;i*i<=n;i++){
        if(n%i==0){
            rea=rea/i*(i-1);
            while(n%i==0)
                n/=i;
        }
    }
    if(n!=1)
        rea=rea/n*(n-1);
    return rea;
}

int main()
{
    int cas,n,m;
    cin>>cas;
    while(cas--){
        cin>>n>>m;
        int ans=0;
        for(int i=1;i*i<=n;i++){
            if(n%i==0){//i或者n/i為公約數的情況
            if(i>=m)//i為公約數 n/i為係數
                ans+=phi(n/i);
            if(i*i!=n&&n/i>=m)//i!=n/i時並且 n/i為公約數的情況
                ans+=phi(i);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


相關文章