HDU4091(2011 Asia Shanghai Regional Contest)
Zombie’s Treasure Chest
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4085 Accepted Submission(s): 836
Problem Description
Some brave warriors come to a lost village. They are very lucky and find a lot of treasures and a big treasure chest, but with angry zombies.
The warriors are so brave that they decide to defeat the zombies and then bring all the treasures back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies are undead and invincible.
Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with infinite quantities. So are sapphires.
Being the priest of the warriors with the magic artifact: computer, and given the size of the chest, the value and size of each types of gem, you should compute the maximum value of treasures our warriors could bring back.
The warriors are so brave that they decide to defeat the zombies and then bring all the treasures back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies are undead and invincible.
Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with infinite quantities. So are sapphires.
Being the priest of the warriors with the magic artifact: computer, and given the size of the chest, the value and size of each types of gem, you should compute the maximum value of treasures our warriors could bring back.
Input
There are multiple test cases. The number of test cases T (T <= 200) is given in the first line of the input file. For each test case, there is only one line containing five integers N, S1, V1, S2, V2, denoting the size of the treasure chest is N and the
size and value of an emerald is S1 and V1, size and value of a sapphire is S2, V2. All integers are positive and fit in 32-bit signed integers.
Output
For each test case, output a single line containing the case number and the maximum total value of all items that the warriors can carry with the chest.
Sample Input
2
100 1 1 2 2
100 34 34 5 3
Sample Output
Case #1: 100
Case #2: 86
線性規劃題目,由於只能取整點 最優點可能取不到 ,因此索性將容量分為兩部分:
1)可以恰好裝翡翠或者藍寶石的
2)剩下的部分
第一部分直接取兩者總利潤的最大值
第二部分直接列舉 看取那種最好
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int cas;
__int64 n,s1,v1,s2,v2;
scanf("%d",&cas);
for(int j=1;j<=cas;j++){
scanf("%I64d%I64d%I64d%I64d%I64d",&n,&s1,&v1,&s2,&v2);
__int64 tot=n/(s1*s2);
__int64 n1=tot*(s1*s2);
__int64 val=0;
if(tot*(s1*s2)/s1*v1>tot*(s1*s2)/s2*v2)
val=tot*(s1*s2)/s1*v1;
else
val=tot*(s1*s2)/s2*v2;
__int64 val2=0;
__int64 n2=n-n1;
if(s1>s2){
for(int i=0;i*s1<=n2;i++){
__int64 ans=i*v1+(n2-i*s1)/s2*v2;
if(val2<ans)
val2=ans;
}
}
else{
for(int i=0;i*s2<=n2;i++){
__int64 ans=i*v2+(n2-i*s2)/s1*v1;
if(ans>val2)
val2=ans;
}
}
//cout<<n1<<" "<<n2<<endl;
//cout<<val<<" "<<val2<<endl;
printf("Case #%d: %I64d\n",j,val+val2);
}
return 0;
}
相關文章
- The 2024 ICPC Asia Nanjing Regional ContestNaN
- The 2021 ICPC Asia Shenyang Regional Contest
- The 2023 ICPC Asia Macau Regional ContestMac
- The 2022 ICPC Asia Nanjing Regional ContestNaN
- The 2022 ICPC Asia Xian Regional Contest
- The 2022 ICPC Asia Hangzhou Regional Programming Contest
- The 2022 ICPC Asia Xian Regional Contest 前六題
- 2018-2019 ACM-ICPC, Asia Seoul Regional Contest——A - CircuitsACMUI
- The 2022 ICPC Asia Nanjing Regional Contest IGDA,和令人疑惑的MNaN
- Chayas - 2023-2024 ICPC, Asia Yokohama Regional Contest 2023, Problem E
- The 2023 ICPC Asia Hangzhou Regional Contest (The 2nd Universal Cup. Stage 22: Hangzhou)
- The 2023 ICPC Asia Jinan Regional Contest (The 2nd Universal Cup. Stage 17: Jinan)補題記錄NaN
- 2017 ACM/ICPC Asia Regional Shenyang Online - 做題記錄ACM
- The 2023 ICPC Asia EC Regionals Online Contest (I)
- The 2024 ICPC Asia East Continent Online Contest (I)AST
- 2018 BACS Regional Programming Contest C. BACS, Scoundrel Shopkeeper and Contiguous Sequence (模擬)
- The 2024 ICPC Asia EC Regionals Online Contest (II) - Problem H. Points Selection
- The 2024 ICPC Asia EC Regionals Online Contest (II) - Problem B. Mountain BookingAI
- 2019-2020 ICPC Southeastern European Regional Programming Contest (SEERC 2019) 補題記錄AST
- 2020-2021 ICPC NERC (NEERC), North-Western Russia Regional Contest (Northern Subregionals) E(離散化+尤拉回路)
- 2024-2025 ICPC, NERC, Southern and Volga Russian Regional Contest 個人題解(A,B,C,G,J,K,L,N)
- Pegging a sub strapon in Shanghai/Suzhou/WuxiAIUX
- Unite Shanghai 2024 全日程曝光AI
- Asia-Tsukuba 2017
- Unite Shanghai 2024,我們回來了AI
- Get yourself a femdom Superior If you are truly submissive in ShanghaiAI
- 2024 (ICPC) Jiangxi Provincial Contest -- Official Contest
- P9825 [ICPC2020 Shanghai R] FibonacciAI
- Mynavi Programming Contest 2021(AtCoder Beginner Contest 201)
- AISing Programming Contest 2021(AtCoder Beginner Contest 202)AI
- hdu2011javaJava
- 2018 Multi-University Training Contest 3 - HDU ContestAI
- The 2024 CCPC Shandong Invitational Contest and Provincial Collegiate Programming Contest
- Toyota Programming Contest 2024#3(AtCoder Beginner Contest 344)
- UNIQUE VISION Programming Contest 2024 Spring(AtCoder Beginner Contest 346)Spring
- KEYENCE Programming Contest 2024(AtCoder Beginner Contest 374)題解
- Toyota Programming Contest 2024#11(AtCoder Beginner Contest 379)
- Toyota Programming Contest 2024#7(AtCoder Beginner Contest 362)
- Weekly Contest 387