POJ2487Farey Sequence(尤拉函式&&法雷級數)

bigbigship發表於2014-07-03

題目連結:http://poj.org/problem?id=2478

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9
題目要求是求出Fn的元素個數,由法雷級數的定義可知

Fn 是由一系列的不能約分的分數a/b(0<a<b<=n&&gcd(a,b)=1)按遞增順序排列組合而成

因此我們很容易的就可以知道 第N項的元素個數為 2,3.。。。。n的尤拉函式值的和

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int N = 1000001;
LL oular[N];
void phi()
{
    for(int i=1;i<N;i++)   oular[i]=i;
    for(int i=2;i<N;i+=2)   oular[i]/=2;
    for(int i=3;i<N;i+=2){
        if(oular[i]==i){
            for(int j=i;j<N;j+=i)
                oular[j]=oular[j]/i*(i-1);
        }
    }
    for(int i=3;i<N;i++)
        oular[i]+=oular[i-1];
}
int main()
{
    phi();
    int n;
    while(~scanf("%d",&n)&&n){
        printf("%I64d\n",oular[n]);
    }
    return 0;
}


相關文章