POJ2487Farey Sequence(尤拉函式&&法雷級數)
題目連結:http://poj.org/problem?id=2478
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9題目要求是求出Fn的元素個數,由法雷級數的定義可知
Fn 是由一系列的不能約分的分數a/b(0<a<b<=n&&gcd(a,b)=1)按遞增順序排列組合而成
因此我們很容易的就可以知道 第N項的元素個數為 2,3.。。。。n的尤拉函式值的和
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int N = 1000001;
LL oular[N];
void phi()
{
for(int i=1;i<N;i++) oular[i]=i;
for(int i=2;i<N;i+=2) oular[i]/=2;
for(int i=3;i<N;i+=2){
if(oular[i]==i){
for(int j=i;j<N;j+=i)
oular[j]=oular[j]/i*(i-1);
}
}
for(int i=3;i<N;i++)
oular[i]+=oular[i-1];
}
int main()
{
phi();
int n;
while(~scanf("%d",&n)&&n){
printf("%I64d\n",oular[n]);
}
return 0;
}
相關文章
- POJ 2478-Farey Sequence(尤拉函式)函式
- 尤拉函式φ函式
- Note -「因數的尤拉函式求和」函式
- 4939 尤拉函式函式
- 尤拉函式入門函式
- 尤拉函式詳解函式
- poj 2478 尤拉函式函式
- 淺談尤拉函式函式
- §3. 復變數的指數函式·尤拉公式變數函式公式
- sequence 和索引函式呼叫索引函式
- 尤拉函式性質和模版函式
- HDU2588GCD(尤拉函式)GC函式
- 轉載:尤拉函式知識點總結及程式碼模板及尤拉函式表函式
- 51nod1040 最大公約數之和 (尤拉函式 )函式
- bzoj2818: Gcd(尤拉函式)GC函式
- B.日記和尤拉函式函式
- MySQL函式大全(字串函式,數學函式,日期函式,系統級函式,聚合函式)MySql函式字串
- 尤拉計劃512題(冪的尤拉總計函式和)函式
- 函式的冪級數展開式函式
- POJ 2048 Longge's problem (尤拉函式 積性函式)函式
- HDU 4002Find the maximum(尤拉函式)函式
- POJ 2407-Relatives-尤拉函式函式
- 數論線性篩總結 (素數篩,尤拉函式篩,莫比烏斯函式篩,前n個數的約數個數篩)函式
- 週期函式的傅立葉級數函式
- HDU 4279 2012網路賽Number(數論 尤拉函式結論約數個數)函式
- 15.5 函式的冪級數展開式函式
- [藍橋杯][演算法提高VIP]尤拉函式演算法函式
- HDU 1695-GCD(容斥原理+尤拉函式)GC函式
- HDU 3501 Calculation 2 (尤拉函式應用)函式
- 51nod1262 扔球(尤拉函式)函式
- 尤拉函式、整除分塊和擴充套件歐幾里得函式套件
- oracle sequence語法Oracle
- 尤拉計劃533題:卡邁克爾函式函式
- HDU3501 Calculation 2(尤拉函式推廣)函式
- 罰函式法函式
- 15.4 由冪級數確定的函式函式
- Python語法—函式及引數傳遞Python函式
- BZOJ 2818 Gcd (莫比烏斯反演 或 尤拉函式)GC函式