FZU1759Super A^B mod C(快速冪取模) 公式
Description
Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,C<=1000000000,1<=B<=10^1000000).
Input
There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.
Output
For each testcase, output an integer, denotes the result of A^B mod C.
Sample Input
3 2 4 2 10 1000
Sample Output
1 24
對於A^B%C 有一個公式 即
A^x = A^(x % Phi(C) + Phi(C)) (mod C)
公式的具體證明:http://hi.baidu.com/aekdycoin/item/e493adc9a7c0870bad092fd9
// A^x = A^(x % Phi(C) + Phi(C)) (mod C),其中x≥Phi(C)
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long LL;
char bb[1000001];
LL a,m;
LL phi(LL n)
{
LL rea=n;
for(int i=2;i*i<=n;i++){
if(n%i==0){
rea=rea-rea/i;
while(n%i==0)
n/=i;
}
}
if(n>1)
rea=rea-rea/n;
return rea;
}
LL quick_mod(LL a,LL b,LL m)
{
LL ans=1;
a%=m;
while(b){
if(b&1){
ans=ans*a%m;
b--;
}
b>>=1;
a=a*a%m;
}
return ans;
}
int main()
{
while(~scanf("%lld",&a)){
scanf("%s",bb);
scanf("%lld",&m);
LL t=phi(m);
int l=strlen(bb);
LL b=0;
for(int i=0;i<l;i++){
b=b*10+bb[i]-'0';
while(b>=t)
b-=t;
}
b+=t;
printf("%lld\n",quick_mod(a,b,m));
}
return 0;
}
相關文章
- Raising Modulo (快速冪取模)AI
- HDU 2685 I won't tell you this is about number theory (數論 公式 快速冪取模)公式
- HDU 1575 Tr A【矩陣快速冪取模】矩陣
- 學習筆記----快速冪取模演算法筆記演算法
- HDU 4686 (推公式+矩陣快速冪)公式矩陣
- 模冪運算-要求演算法返回冪運算a^b的計算結果與1337取模後的結果演算法
- 快速冪
- 尤拉計劃717:取模公式之和公式
- 冪的一個公式(一)公式
- 冪的一個公式(二)公式
- POJ 3233-Matrix Power Series( S = A + A^2 + A^3 + … + A^k 矩陣快速冪取模)矩陣
- 取冪運算--C語言描述C語言
- 矩陣快速冪矩陣
- Gem Mod音訊模擬工具音訊
- 矩陣快速冪(快忘了)矩陣
- 矩陣快速冪總結矩陣
- Quick Pow: 如何快速求冪UI
- 【矩陣乘法】【快速冪】遞推矩陣
- 快速冪的初步認識(Java)Java
- 矩陣快速冪加速最短路矩陣
- Codeforces-Round#548(Div.2)-C-Edgy Trees-快速冪
- 費馬小定理 + 費馬大定理 + 勾股數的求解 + 快速冪 + 矩陣快速冪 【模板】矩陣
- HDU3221Brute-force Algorithm(矩陣快速冪&&指數降冪)Go矩陣
- ACM — Prepared for New Acmer 快速冪法ACM
- HDU 1575 Tr A(矩陣快速冪)矩陣
- 快速冪演算法及其擴充演算法
- HDU 4565 So Easy!(矩陣快速冪)矩陣
- 快速選取excel中所有包含公式的單元格的方法技巧Excel公式
- 冪的計算(C#)C#
- PAT-B 1059 C語言競賽【模擬】C語言
- ax²+bx+c≡0 mod m 和 x²≡a mod p的解存在性分析
- P3390 【模板】矩陣快速冪矩陣
- HDU 4965 Fast Matrix Calculation(矩陣快速冪)AST矩陣
- 計蒜客模擬賽D2T1 蒜頭君的兔子:矩陣快速冪矩陣
- №20181217部落格賽事:求公式A^2+B^3=C^4公式
- HDU 3221Brute-force Algorithm(降冪公式 神似hdu4549)Go公式
- POI讀取公式的值公式
- 三數取中公式思路公式