POJ2492(種類並查集)
題目連結:http://poj.org/problem?id=2492
A Bug's Life
Time Limit: 10000MS | Memory Limit: 65536K | |
Total Submissions: 27388 | Accepted: 8907 |
Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
題目意思就是 給定n只蟲子 不同性別的可以在一起 相同性別的不能在一起
給你m對蟲子 判斷中間有沒有同性別在一起的;
我們把同性的放到一個集合裡 如果一個集合裡出現了異性 則說明存在同性戀在一起
假設 x 為一種性別 x+n為與其相反的性別
若a,b為同性 的 我們則可以把判斷 (a,b+n) (b,a+n)為異性反之亦然;
程式碼如下:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 5000;
int par[maxn];
void init(int n){
for(int i=0;i<=n;i++)
par[i]=i;
}
int find(int x){
if(x!=par[x])
par[x]=find(par[x]);
return par[x];
}
void Union(int a,int b){
int x=find(a);
int y=find(b);
if(x!=y)
par[x]=y;
}
bool judge(int x,int y){//判斷是否為同性,異性為真,同性為假
x=find(x);
y=find(y);
if(x!=y)
return true;
return false;
}
int main()
{
int t,n,m,cas=1;
scanf("%d",&t);
for(int i=1;i<=t;i++){
scanf("%d%d",&n,&m);
init(n*2);
bool l=1;
int x,y;
while(m--){
scanf("%d%d",&x,&y);
if(judge(x,y)||judge(x+n,y+n)){
Union(x,y+n);//把同性的加到一個集合裡
Union(x+n,y);
}
else
l=0;
}
if(i!=1)
puts("");
printf("Scenario #%d:\n",cas++);
if(l)
printf("No suspicious bugs found!\n");
else
printf("Suspicious bugs found!\n");
}
return 0;
}
相關文章
- 【轉】種類並查集並查集
- 各種並查集並查集
- 並查集(一)並查集的幾種實現並查集
- POJ-1182-食物鏈(並查集種類)並查集
- acdream群賽(4)Bad Horse(種類並查集)並查集
- 並查集到帶權並查集並查集
- 轉載:一個python並查集類Python並查集
- 【並查集】【帶偏移的並查集】食物鏈並查集
- 3.1並查集並查集
- 並查集(小白)並查集
- 並查集(Union Find)並查集
- 並查集應用並查集
- The Door Problem 並查集並查集
- 並查集練習並查集
- 並查集的使用並查集
- 並查集—應用並查集
- 寫模板, 並查集。並查集
- 並查集跳躍並查集
- 食物鏈(並查集)並查集
- 並查集(二)並查集的演算法應用案例上並查集演算法
- 並查集是一種怎樣的資料結構?並查集資料結構
- The Suspects-並查集(4)並查集
- [leetcode] 並查集(Ⅰ)LeetCode並查集
- [leetcode] 並查集(Ⅱ)LeetCode並查集
- [leetcode] 並查集(Ⅲ)LeetCode並查集
- 並查集演算法並查集演算法
- 並查集深度應用並查集
- 並查集java實現並查集Java
- 並查集-Java實現並查集Java
- 並查集題目合集並查集
- 並查集以及應用並查集
- 並查集的應用並查集
- 暢通工程(並查集)並查集
- (Day3)並查集並查集
- 並查集擴充套件並查集套件
- 簡單易懂的並查集演算法以及並查集實戰演練並查集演算法
- POJ 1182(食物鏈-另類做法【拆點】)[Template:並查集]並查集
- 【並查集】一種與時間賽跑的巧妙演算法並查集演算法