差分約束系統+poj1201

u010660276發表於2014-01-03
Language:
Intervals
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 19858   Accepted: 7509

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

題意:給你一些區間,【a,b】從中至少取c個整數點,問最後最少需要取多少點。
思路:又是一個差分約束系統,前一段時間做過一個,但還是不太熟悉。
將區間[ai,bi]的每個端點看做一個頂點,以dist[i+1]表示源點xi之間至少有與集合Z相同元素的個數。如果將至少含有的相同元素的個數看做邊的權值則一個區間[ai,bi]的兩個端點的dist[ai]dist[bi+1]分別表示源點xai-1bi的距離。那麼區間[ai,bi+1]又可以看做什麼呢?可以看做aibi的一條邊。依據題意 xaibi構成了一個邊權三角形dist[bi+1]-dist[ai]>=ai->bi,即dist[bi+1]-dist[ai]>=ci;所以變形一下就得:dist[bi+1]>=dist[ai]+ci;注意:這個結果只是題目的要求,所以我們if(dist[bi+1]<dist[ai]+ci) dist[bi+1]=dist[ai]+ci;這也決定了求的是最長路徑。

如果只有題目所給的約束條件的話,是遠遠不夠的。所以還需要挖掘隱藏的條件:0<=dist[i+1]-dist[i]<=1。有了這個條件我們便可以建立資料結構了,然後我們以出現的最小元素min1為源點spfadist[max1]就是解了。

又看了一下什麼時候取最小值,什麼時候取最大值,d[v] <= d[u] + w(u, v), 初始化d[]為-INF. 這樣求出的d[]就是滿足條件的最小值。原因很簡單,因為d[i] 是從-INF開始增大,根據不等式逐漸增大,當滿足所有不等式時,那麼d[i]肯定是最小的了。d[v] >= d[u] + w(u, v), 初始化d[]為INF.這樣求出的d[]就是最大值。原因和上面一樣,因為是從INF逐漸減小的,當滿足完所有條件時,就停止。那麼d[i]是最大的了。 下面是程式碼:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
const int maxn=50050;
const int MAXN=200000;
const int INF=1000000000;
struct node
{
    int v,next,c;
}e[MAXN];
int pre[maxn],dis[maxn];
bool vis[maxn];
int N,num;
int s,en;
void init()
{
    memset(pre,-1,sizeof(pre));
    num=0;
}
void add_edge(int x,int y,int c)
{
    e[num].v=x;
    e[num].next=pre[y];
    e[num].c=c;
    pre[y]=num++;
}
int SPFA()
{
    for(int i=s;i<=en;i++)
    {
        dis[i]=-INF;
        vis[i]=false;
    }
    queue<int> q;
    q.push(s);
    dis[s]=0;
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        vis[t]=false;
        for(int i=pre[t];i!=-1;i=e[i].next)
        {
            int v=e[i].v;
            if(dis[v]<dis[t]+e[i].c)
            {
                dis[v]=dis[t]+e[i].c;
                if(!vis[v])
                {
                    q.push(v);
                    vis[v]=true;
                }
            }
        }
    }
    return dis[en];
}
int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
    #endif

    while(scanf("%d",&N)!=EOF)
    {
        int a,b,c;
        init();
        s=INF;en=-INF;
        for(int i=0;i<N;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            add_edge(b+1,a,c);
            s=min(s,a);
            en=max(en,b+1);
        }
        for(int i=s;i<en;i++)
        {
            add_edge(i+1,i,0);
            add_edge(i,i+1,-1);
        }
        cout<<SPFA()<<endl;
    }
    return 0;
}


相關文章