Online Judge計算整數的和
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10
15
6
我的程式碼如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <errno.h>
int main(int argc,char **argv){
int row; //將要輸入的行
int rowmax;//每行輸入整數個數
scanf("%d",&row);
int *pt[row];
int result[row];
memset(result,0,sizeof(int) * row);
int i=row;
for(;row>0;row--){
scanf("%d",&rowmax);
pt[row-1]=(int *)malloc(rowmax * sizeof(int));
if(pt[row-1]==NULL){
perror(strerror(errno));
}
else{
for(;rowmax>0;rowmax--){
scanf("%d",pt[row-1]);
result[row-1]+=*pt[row-1];
pt[row-1]++;
}
}
}
for(;i>0;i--)
printf("%d\n\n",result[i-1]);
return 0;
}
注:我動態申請的空間用完後沒有釋放,因不知指標陣列空間如何釋放。
下面程式碼是別人所寫,拿來對比:
#include <stdio.h>
#include <stdlib.h>
#include <ctype.h>
#include <string.h>
int
main (
int
argc,
char
*argv[])
{
int
row;
int
i,j=0;
char
num;
int
* result=NULL;
printf
(
"Enter the row: "
);
scanf
(
"%d"
,&row);
result =
malloc
(row*
sizeof
(
int
));
memset
(result,0,
sizeof
(result));
getchar
();
for
(i=0;i<row;i++)
{
result[i] = 0;
num =
getchar
();
while
(1)
{
num =
getchar
();
if
(num ==
'\n'
)
{
break
;
}
else
if
(num !=
' '
)
{
result[i]+=(num-0x30);
}
}
}
for
(i=0;i<row;i++)
{
printf
(
"%d\n\n"
,result[i]);
}
return
0;
}
相關文章
- 帶你快速搭建自己的Online Judge平臺
- Online Judge——1000.A+B Problem(c++)C++
- 超大整數的加減乘除計算方法
- FCC - 253 計算一個整數的階乘
- Python使用遞迴法和函數語言程式設計計算整數各位之和Python遞迴函數程式設計
- Java中計算整數中唯一數字數量的3種方法Java
- MySQL 中 整數型別的儲存和範圍計算過程詳解MySql型別
- Java計算百分比保留整數Java
- C語言程式設計-長整數加法運算C語言程式設計
- 用VBA計算EXCEL中的行數和列數Excel
- 請寫一個整數計算器,支援加減乘三種運算和括號。Python版本Python
- java大整數四則運算Java
- 運算整數C/C++位運算技巧C++
- python整數和變數Python變數
- Shell階段02 shell變數運算(整數運算/小數運算), shell變數案例變數
- 6-2 計算素數和
- stackoverflow 提問:“計算兩個整數的最小公倍數的最有效方法是什麼?”
- jquery judge element existjQuery
- Aizu Online Judge Introduction to Programming I C語言實現 ITP1 Topic # 1AIC語言
- 計算機計算小數除法的陷阱計算機
- win10系統下如何分整數分割槽_windows10怎樣計算硬碟分割槽整數Win10Windows硬碟
- 引數為二叉樹和一個整數,求所有和為該整數的路徑二叉樹
- 大整數運算C#實現C#
- 看板數量的計算
- 列印1-100之間所有9的倍數的整數,統計個數 及 總和
- 圖解計算機中的數值範圍和浮點運算圖解計算機
- 計算位數最高達300位的兩個非負整數的乘積,C語言程式設計實現C語言程式設計
- C/C++模運算(正負整數)C++
- 第6周-統計正數和負數的個數然後計算這些數的平均值
- 如何用位運算實現整數的加減法
- linux 快速計算檔案數和目錄數 (轉)Linux
- 計算某個範圍內的質數和的辦法
- 使用AWK計算某一列的所有數值和
- 3069 求n個整數的和
- 有一組整數資料,全部除以一個整數a,使得餘數是同n種數字,如何計算出這個整數a的全部可能。
- 計算1000以內所有偶數和.
- 【操作】調整Online Redo Logs大小(Resizing Oracle Online Redo Logs)Oracle
- 輸入一個整數,返回這個整數的位數