BFS廣度優先搜尋(5)(亦可以用DFS)--hdu1241(poj1562)(基礎題)

Sly_461發表於2016-09-14
Oil Deposits

                                        Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2


         這道題就是給你一個二維陣列,‘@’周圍八個方向的‘@’都是屬於同一塊區域,問這個二維陣列被分為幾個區域。簡單的BFS,直接向八個方向搜尋,BFS與DFS兩種方法我都寫了,BFS程式碼

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
char map[105][105];
int vis[105][105];
int n,m;
int d[8][2]={{0,1},{0,-1},{1,0},{-1,0},
            {1,1},{-1,-1},{-1,1},{1,-1}};       //八個方向
struct node{
	int x;
	int y;
};
void Bfs(int x,int y){
	vis[x][y]=1;
	queue<node>q;
	node s,e;
	int i;
	s.x=x;
	s.y=y;
	q.push(s);
	while(!q.empty()){
		s=q.front();
		q.pop();
		for(i=0;i<8;i++){
			int xx=s.x+d[i][0];
			int yy=s.y+d[i][1];
			if(xx<0||yy<0||xx>=n||yy>=m)
				continue;
			if(map[xx][yy]=='*')continue;
			if(vis[xx][yy])continue;
			vis[xx][yy]=1;
			e.x=xx;
			e.y=yy;
			q.push(e);
		}
	}
}
int main()
{
	int i,j;
	int ans;
	while(scanf("%d %d",&n,&m)!=EOF){
		if(!n&&!m)break;
		memset(vis,0,sizeof(vis));
		ans=0;
		for(i=0;i<n;i++){
			scanf("%s",map[i]);
		}
		for(i=0;i<n;i++){
			for(j=0;j<m;j++){
				if(map[i][j]=='@'&&!vis[i][j]){
					Bfs(i,j);
					ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

DFS程式碼:

#include<stdio.h>
#include<string.h>
int n,m;
char map[105][105];
int vis[105][105];
int d[8][2]={{0,1},{0,-1},{1,0},{-1,0},
            {1,1},{-1,-1},{-1,1},{1,-1}};  //八個方向
void Dfs(int x,int y){
	int i;
	for(i=0;i<8;i++){
		int xx=x+d[i][0];
		int yy=y+d[i][1];
		if(xx<0||yy<0||xx>=n||yy>=m)
			continue;
		if(map[xx][yy]=='*')continue;
		if(vis[xx][yy])continue;
		vis[xx][yy]=1;
		Dfs(xx,yy);
	}
}
int main()
{
	int i,j;
	int ans;
	while(scanf("%d %d",&n,&m)!=EOF){
		if(!n&&!m)break;
		ans=0;
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++){
			scanf("%s",map[i]);
		}
		for(i=0;i<n;i++){
			for(j=0;j<m;j++){
				if(map[i][j]=='@'&&!vis[i][j])
				{
					Dfs(i,j);
					ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

    兩種方法:第一個是DFS


相關文章