BFS廣度優先搜尋(4)--hdu2717(poj3278)(基礎題)

Sly_461發表於2016-09-13
 Catch That Cow

                                               Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the pointsX- 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N andK

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


            這道題題意:直線座標,從n走到k,給出了三種走的方式:x-1,x+1,x*2(x為當前座標),問最少需要走多少次。
         直接套BFS: 給定初始狀態跟目標狀態,要求從初始狀態到目標狀態的最短路。對所有狀況進行一次搜尋,最先找到的肯
定就是時間最少的。
 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,k;
int vis[100005];
struct node{
	int x;
	int time;
};
void Bfs(int x){
	int i;
	queue<node>q;
	memset(vis,0,sizeof(vis));
	node s,e;
	vis[x]=1;
	s.x=x;
	s.time=0;
	q.push(s);
	while(!q.empty()){
		s=q.front();
		q.pop();
		if(s.x==k)printf("%d\n",s.time);
		for(i=0;i<3;i++){
			int xx;
			if(i==0)          //三種走的方式
				xx=s.x-1;
			else if(i==1)
				xx=s.x+1;
			else xx=s.x*2;
			if(xx<0||xx>100000)continue;
			if(vis[xx])continue;
			vis[xx]=1;
			e.x=xx;
			e.time=s.time+1;
			q.push(e);
		}
	}
}
int main()
{
	while(scanf("%d %d",&n,&k)!=EOF){
		Bfs(n);
	}
	return 0;
}

相關文章