Large Division (大數取餘,有個坑爹的地方)
Large Division
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Description
Given two integers, a and b, you should checkwhether a is divisible by b or not. We know that an integer ais divisible by an integer b if and only if there exists an integer csuch that a = b * c.
Input
Input starts with an integer T (≤ 525),denoting the number of test cases.
Each case starts with a line containing two integers a(-10200 ≤ a ≤ 10200) and b (|b| >0, b fits into a 32 bit signed integer). Numbers will not contain leadingzeroes.
Output
For each case, print the case number first. Then print 'divisible'if a is divisible by b. Otherwise print 'not divisible'.
Sample Input
6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101
Sample Output
Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible
這是一道很普通的大數取餘的題目,可是有個地方卡了半天TT,卡住的地方就是程式註釋處
//Memory: 1508 KB Time: 4 MS
//Language: C++ Result: Accepted
#include <iostream>
#include <string>
using namespace std;
int main()
{
string num;
string::iterator it;
int T, ca;
long long carry, b; // !!!!long long才行!!!!
while(cin >> T)
{
ca = 1;
while(T--)
{
cin >> num >> b;
it = num.begin();
carry = 0;
if(num[0] == '-') it++;
for(; it != num.end(); it++)
{
carry = carry * 10 + *it - '0';
carry %= b;
}
if(!carry) cout << "Case" << " " << ca++ << ": divisible" << endl;
else cout << "Case" << " " << ca++ << ": not divisible" << endl;
}
}
return 0;
}
相關文章
- 十二個坑爹的Python陷阱Python
- 坑爹的Sun JDKJDK
- 最近線上發生的兩個坑爹鍋
- 坑爹的驗證碼。。
- 坑爹的Oracle 11.2.0.3Oracle
- 坑爹的IE8
- 坑爹的Python陷阱(避坑指南)Python
- 史上最坑爹的程式碼!個個讓人崩潰!
- 一有不慎,廣泛傳播,坑爹啊
- 餘數的餘數
- java基礎-取餘數,取商Java
- 坑爹的UEditor與springMVC的結合SpringMVC
- 01—Hbuilder—js—除法、取餘數UIJS
- NDK的坑爹問題make: *** No rule to make target
- 踩坑CBO,解決那些坑爹的SQL優化問題SQL優化
- Misfit新增游泳追蹤功能 需付費購買有點坑爹
- Apple Watch延保費大降!老使用者喊坑爹APP
- JavaScript取餘數程式碼例項JavaScript
- 【Python有坑系列】交換兩個陣列的切片,有坑Python陣列
- sql_取結果的整數及取餘數_last_day__add_monthsSQLAST
- mybatis 提示404跳轉異常因為spring下面有兩個modelandview,坑爹又坑娘MyBatisSpringView
- 坑爹專案「spring-cloud-alibaba」,我們也來一個SpringCloud
- javascript變數宣告需要注意的一個地方JavaScript變數
- Python中如何取餘數?建議收藏!Python
- 坑爹的IE6相容性問題
- 坑爹的導航欄返回鍵(navigationItem.backButtonBarItem)Navigation
- JavaScript 有個 Unicode 的天坑JavaScriptUnicode
- Java變數命名前倆個字母僅含有一個大寫字母的坑Java變數
- Zend Studio導致PHP插入資料庫中文亂碼【坑了個爹】PHP資料庫
- abc135d 模13餘5的數的個數
- js獲取當前月份剩餘的天數程式碼JS
- 創業故事多:合夥人的悲催坑爹二三事創業
- jquery獲取ajax傳遞的值一個需要注意的地方jQuery
- 有一組整數資料,全部除以一個整數a,使得餘數是同n種數字,如何計算出這個整數a的全部可能。
- 骷髏坑人小技巧1[python]:坑爹遊戲[tkinter]Python遊戲
- Linux 發行版 Ultimate Edition 3.9 太坑爹了Linux
- Array Division
- 記一次坑爹的golang 二維map判斷問題Golang