Large Division (大數取餘,有個坑爹的地方)

御史大夫發表於2012-09-01

Large Division

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given two integers, a and b, you should checkwhether a is divisible by b or not. We know that an integer ais divisible by an integer b if and only if there exists an integer csuch that a = b * c.

Input

Input starts with an integer T (≤ 525),denoting the number of test cases.

Each case starts with a line containing two integers a(-10200 ≤ a ≤ 10200) and b (|b| >0, b fits into a 32 bit signed integer). Numbers will not contain leadingzeroes.

Output

For each case, print the case number first. Then print 'divisible'if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

這是一道很普通的大數取餘的題目,可是有個地方卡了半天TT,卡住的地方就是程式註釋處

//Memory: 1508 KB 		Time: 4 MS
//Language: C++ 		Result: Accepted

#include <iostream>
#include <string>
using namespace std;

int main()
{
    string num;
    string::iterator it;
    int T, ca;
    long long carry, b; // !!!!long long才行!!!!
    while(cin >> T)
    {
        ca = 1;
        while(T--)
        {
            cin >> num >> b;
            it = num.begin();
            carry = 0;
            if(num[0] == '-') it++;
            for(; it != num.end(); it++)
            {
                carry = carry * 10 + *it - '0';
                carry %= b;
            }
            if(!carry) cout << "Case" << " " << ca++ << ": divisible" << endl;
            else cout << "Case" << " " << ca++ << ": not divisible" << endl;
        }
    }
    return 0;
}



相關文章