The Center of Gravity(一道很很簡單的幾何題)

御史大夫發表於2012-09-01

The Center of Gravity

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2994    Accepted Submission(s): 1668

原題連結:點選開啟連結


Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
 

Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
 

Output
For each case, print the coordinate, accurate up to 1 decimal places.
 

Sample Input
2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0
 

Sample Output
3.0 2.7 2.0 2.3
 

Source
 

Recommend
xhd


AC CODE:

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    double x[3], y[3];
    int T;
    while(cin >> T && T)
    {
        while(T--)
        {
            for(int i = 0; i < 3; i++)
                cin >> x[i] >> y[i];
            x[0] += x[1] + x[2];
            y[0] += y[1] + y[2];
            printf("%.1lf %.1lf\n", x[0] / 3.0, y[0] / 3.0);
        }
    }
    return 0;
}


相關文章