POJ 2240 Arbitrage(Floyd最短路)

KeepTing發表於2017-03-02
Arbitrage
Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 22202 Accepted: 9426


Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.


Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.


Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".


Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output

Case 1: Yes

Case 2: No


題意:給出n種貨幣,以及m種貨幣的匯率,問有沒有一種貨幣,經過多次兌換後獲得更多的價值(比如1美元經過多次兌換後獲得1.2美元),如果有輸出Yes,否則輸出No;


思路:可以看成一個圖,每種貨幣代表圖的頂點,兩種貨幣之間的匯率代表兩點之間路徑的權值,這樣就構成一個有向圖,然後用最短路思想改進Floyd演算法,算出任意兩點間的最大兌換價值 ,最後查詢是否存在一種貨幣對自己的匯率大於1,,,


AC程式碼:

#include<stdio.h>
#include<string.h>
char s[105][105],a[105],b[105];
int main(){
    int i,j,k;
    int n,m;
    double v;
    double map[35][35];
    int t=1;
    while(scanf("%d",&n),n){
        for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                if(i==j)
                    map[i][j]=1;  //對自己的匯率為1
                else
                    map[i][j]=0;
            }
        }
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        scanf("%d",&m);
        for(i=0;i<m;i++){
            scanf("%s%lf%s",a,&v,b);
            for(j=0;j<n;j++){
                if(strcmp(a,s[j])==0)
                    break;
            }
            for(k=0;k<n;k++){
                if(strcmp(b,s[k])==0)
                    break;
            }
            map[j][k]=v;    	//找到對應的匯率並賦值
        }
	///Floyd求任意兩點間的最大兌換值
        for(k=0;k<n;k++)
            for(i=0;i<n;i++)
                for(j=0;j<n;j++){
                    if(map[i][k]*map[k][j]>map[i][j])
                        map[i][j]=map[i][k]*map[k][j];
                }


        for(i=0;i<n;i++){	
            if(map[i][i]>1) ///是否存在貨幣,對自己的匯率大於1
                break;
        }
        if(i==n)
            printf("Case %d: No\n",t);
        else
            printf("Case %d: Yes\n",t);
            t++;
    }
    return 0;
}



相關文章