HDU 5131 Song Jiang's rank list(排序)
題意看樣例就可以了啊。
簡單的二級排序+暴力查詢。
Song Jiang's rank list
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 264 Accepted Submission(s): 137
Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from
different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.
In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
Input
There are no more than 20 test cases.
For each test case:
The first line is an integer N (0<N<200), indicating that there are N outlaws.
Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.
The next line is an integer M (0<M<200) ,indicating that there are M queries.
Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
For each test case:
The first line is an integer N (0<N<200), indicating that there are N outlaws.
Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.
The next line is an integer M (0<M<200) ,indicating that there are M queries.
Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed.
Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
Sample Input
5
WuSong 12
LuZhishen 12
SongJiang 13
LuJunyi 1
HuaRong 15
5
WuSong
LuJunyi
LuZhishen
HuaRong
SongJiang
0
Sample Output
HuaRong 15
SongJiang 13
LuZhishen 12
WuSong 12
LuJunyi 1
3 2
5
3
1
2
Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
#define mod 1000000007
#define Read() freopen("autocomplete.in","r",stdin)
#define Write() freopen("autocomplete.out","w",stdout)
#define Cin() ios::sync_with_stdio(false)
using namespace std;
inline int read()
{
char ch;
bool flag = false;
int a = 0;
while(!((((ch = getchar()) >= '0') && (ch <= '9')) || (ch == '-')));
if(ch != '-')
{
a *= 10;
a += ch - '0';
}
else
{
flag = true;
}
while(((ch = getchar()) >= '0') && (ch <= '9'))
{
a *= 10;
a += ch - '0';
}
if(flag)
{
a = -a;
}
return a;
}
void write(int a)
{
if(a < 0)
{
putchar('-');
a = -a;
}
if(a >= 10)
{
write(a / 10);
}
putchar(a % 10 + '0');
}
const int maxn = 320;
struct node
{
int num;
string str;
} f[maxn];
bool cmp(node a, node b)
{
if(a.num == b.num) return a.str < b.str;
return a.num > b.num;
}
int vis[maxn];
int kp[maxn];
int main()
{
Cin();
int n, k;
map<string, int>mp;
while(~scanf("%d",&n) && n)
{
for(int i = 0; i < n; i++)
cin >>f[i].str>>f[i].num;
sort(f, f+n, cmp);
int ans = 0;
for(int i = 0; i < n; i++)
{
cout<<f[i].str<<" "<<f[i].num<<endl;
mp[f[i].str] = f[i].num;
if(vis[f[i].num])continue;
kp[ans++] = f[i].num;
vis[f[i].num] = 1;
}
cin >>k;
string s;
while(k--)
{
cin >>s;
int xans = 0;
int xp = mp[s];
int sx;
for(int i = 0; i < n; i++)
{
if(f[i].num == xp)
{
sx = i+1;
break;
}
}
for(int i = 0; i < n; i++)
{
if(f[i].str == s) break;
else if(f[i].num == xp) xans++;
}
cout<<sx;
if(xans) cout<<" "<<xans+1;
cout<<endl;
}
}
}
相關文章
- R排序sort、order、rank、arrange排序
- 分析函式——排序排列(rank、dense_rank、row_number)函式排序
- SQL SERVER 排序函式ROW_NUMBER、RANK、DENSE_RANK、NTILESQLServer排序函式
- python list 排序Python排序
- HDU 4857 逃生(拓撲排序)排序
- Java中List的排序Java排序
- C# list物件排序C#物件排序
- mysql自動排序函式dense_rank() over()、rank() over()、row_num() over()用法和區別MySql排序函式
- HDU4857逃生(拓撲排序)排序
- HDU1106--排序排序
- python如何將list排序Python排序
- Java基礎系列—List排序Java排序
- python list 排序問題Python排序
- List根據時間排序排序
- rank() 與dense_rank()分析
- rank
- HDU 4857-逃生(反向拓撲排序-按條件排序)排序
- HDU 1040 As Easy As A+B(堆排序)排序
- unsupported operand type(s) for +: ‘range‘ and ‘list‘
- List資料多重規則排序排序
- HDU 4944 FSF’s game(計數遊戲)GAM遊戲
- 分析函式DENSE_RANK 和 RANK函式
- PAT甲級-1012. The Best Rank (25)並列排序排序
- HDU 2689 【歸併排序求逆序對】排序
- HDU 5438 Ponds (拓撲排序應用+DFS)排序
- HDU 2020 絕對值排序排序
- List排序用Collections.sort and Comparator排序
- List集合按照由小到大排序或者由大到小排序排序
- HDU5348 MZL's endless loop (搜尋)OOP
- hdu 1811 並查集+拓撲排序並查集排序
- rank,dense_rank,row_number 分析函式函式
- Oracle:Rank,Dense_Rank,Row_Number比較Oracle
- python用List的內建函式list.sort進行排序Python函式排序
- List排序Collections.sort 重寫compare排序
- Mac文字排序編輯工具:Magic Sort ListMac排序
- Java 8 比較器:如何對 List 排序Java排序
- PaddleSeg2.8訓練驗證時報錯[Hint: Expected axis >= -rank && axis < rank == true, but received axis >= -rank && axis < rank:0 != true:1.]
- 【SQL 學習】分析函式之RANK() DENSE_RANK ()SQL函式