HDU 5119 Happy Matt Friends(簡單二維dp)
題意不再說了,就是一個二維的dp,維持取最大值是多少。
Happy Matt Friends
Time Limit: 6000/6000 MS (Java/Others) Memory Limit: 510000/510000 K (Java/Others)Total Submission(s): 608 Accepted Submission(s): 229
Problem Description
Matt has N friends. They are playing a game together.
Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.
Matt wants to know the number of ways to win.
Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.
Matt wants to know the number of ways to win.
Input
The first line contains only one integer T , which indicates the number of test cases.
For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).
In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).
In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
Sample Input
2
3 2
1 2 3
3 3
1 2 3
Sample Output
Case #1: 4
Case #2: 2
Hint
In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.
Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
#define mod 1000000007
using namespace std;
const int maxn = 1<<20;
inline int read()
{
char ch;
bool flag = false;
int a = 0;
while(!((((ch = getchar()) >= '0') && (ch <= '9')) || (ch == '-')));
if(ch != '-')
{
a *= 10;
a += ch - '0';
}
else
{
flag = true;
}
while(((ch = getchar()) >= '0') && (ch <= '9'))
{
a *= 10;
a += ch - '0';
}
if(flag)
{
a = -a;
}
return a;
}
void write(int a)
{
if(a < 0)
{
putchar('-');
a = -a;
}
if(a >= 10)
{
write(a / 10);
}
putchar(a % 10 + '0');
}
LL dp[45][maxn+100];
int num[45];
int main()
{
int T;
cin >>T;
int Case = 1;
while(T--)
{
int n, m;
n = read();
m = read();
for(int i = 1; i <= n; i++) num[i] = read();
memset(dp, 0, sizeof(dp));
dp[0][0] = 1LL;
for(int i = 1; i <= n; i++)
{
for(int j = 0; j <= maxn-5; j++)
{
dp[i][j] = max(dp[i][j], dp[i-1][j]+dp[i-1][j^num[i]]);
}
}
LL sum = 0;
for(int i = m; i <= maxn-5; i++) sum += dp[n][i];
printf("Case #%d: ", Case++);
cout<<sum<<endl;
}
}
相關文章
- HDU 5119 Happy Matt Friends(DP)APP
- HDU 1227 Fast Food(簡單二維dp)AST
- My Friends, Happy XmasAPP
- URAL 1577. E-mail(簡單二維dp)AI
- hdu 1069 Monkey and Banana(簡單dp)NaN
- hdu 3401 單調佇列+DP佇列
- HDU 1466 計算直線的交點數(簡單dp)
- hdu4374單調佇列+dp佇列
- PHP生成簡單二維碼PHP
- 二維碼簡單封裝封裝
- HDU-3172 Virtual Friends 並查集+map並查集
- HDU 3530 Subsequence (dp+單調佇列)佇列
- HDU 2888 Check Corners(二維RMQ)MQ
- 簡單的Java二維碼應用Java
- HDU 3853 LOOPS(概率dp)OOP
- HDU 4669 Mutiples on a circle (DP , 統計)
- 用java做一個簡單的二維碼Java
- hdu 3665Seaside(簡單floyd)IDE
- HAPPYEO電子琴簡單破解 (1千字)APP
- 【基礎dp】HDU 1260 Tickets
- HDU 4455 Substrings(預處理+dp)
- phpqrcode生成動態二維碼簡單例項PHP單例
- hdu5365 簡單幾何問題
- c#簡單實現二維陣列和二維陣列列表List<>的轉置C#陣列
- Binary Tree Traversals(HDU1710)二叉樹的簡單應用二叉樹
- 簡單易用的二維碼掃描工具:QR Capture for MacAPTMac
- javascript實現二維陣列實現簡單介紹JavaScript陣列
- 使用 Swift 建立簡單的二維碼掃描應用Swift
- HDU 6415 Rikka with Nash Equilibrium (DP)UI
- HDU 3853 LOOPS:期望dp【網格型】OOP
- 【dp】HDU - 1069 Monkey and BananaNaN
- HDU 5326 Work (基礎樹形dp)
- hdu 4123 樹形DP+RMQMQ
- HDU 4770 Lights Against Dudely(列舉所有狀態 當然壯壓dp會很簡單)AI
- hdu 4287Intelligent IME(簡單hash)Intel
- hdu 1326 java (理解起來很簡單)Java
- URAL 1658. Sum of Digits(簡單dp)Git
- HDU3415 Max Sum of Max-K-sub-sequence (DP+單調佇列)佇列