HDU 4465 Candy(組合+log優化)

畫船聽雨發表於2014-11-29

題目大意:給你兩個罐子,裡面有糖果每次只能從一個罐子裡面取一個糖果,開啟A的概率為p,問當一個罐子取完之後,另一個罐子剩糖果的期望是多少。

我們可以知道最少是取第n+1次的時候才會有一個罐子為空,我們可以推出組合公式:

(n-k)*C(n+k, k)*((1-p)^(n+1)*p^k+(1-p)^k*p^(n+k));0 <= k && k <= n-1。

求一個和就是所有的組合情況了,但是組合數很大我們可以用log來進行優化。

我們已知:C(n,m) = m!/n!/(m-n)! = log(m!)/log(n!)/log(m-n)。

m!= 1*2*……*m = log(1)+log(2)+……+log(m).

先打表在直接求就可以了啊。

C(m,n)=exp(logC(m,n))

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2229    Accepted Submission(s): 958
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <time.h>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
///#define LL long long
#define LL __int64
#define INF 0x3f3f3f
#define PI 3.1415926535898
#define mod 1000000007


using namespace std;

const int maxn = 505000;

double f[maxn];
double logc(int m, int n)///C(n,m) = m!/n!/(m-n)!
{
    return f[m]-f[n]-f[m-n];
}

int main()
{
    f[0] = 0;
    for(int i = 1; i <= 400005; i++) f[i] = f[i-1]+log(i*1.0);
    int Case = 1;
    int n;
    double p;
    while(~scanf("%d %lf",&n, &p))
    {
        double sum = 0.0;
        for(int k = 0; k < n; k++)
        {
            ///sum += (n-k)*C(n+k, k)*((1-p)^(n+1)*p^k+(1-p)^k*p^(n+k));
            sum += 1.0*(n-k)*(exp(logc(n+k, k)+(n+1)*1.0*log(1.0-p)+k*1.0*log(p*1.0)) +  exp(logc(n+k, k)+(n+1)*1.0*log(p*1.0)+k*1.0*log(1.0-p)));
        }
        printf("Case %d: %.6lf\n",Case++, sum);
    }
}


相關文章