HDU 5067 Harry And Dig Machine(狀壓dp)
感覺這兩天怎麼老是遇到狀壓啊。。。。
數字20以下,首想狀壓啊、、、
不過這題犯抽忘記考慮沒有石頭的時候了啊。
簡單的狀壓:表示狀態為j時以第i的作為結束。
PS:這題也在表揚大藍翔的挖掘機技術啊。醉了啊。。。
Harry And Dig Machine
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 468 Accepted Submission(s): 170
Problem Description
As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English,
and even algorithm.
Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
Input
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m.(1≤n,m≤50).
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0≤a[i][j]≤100 , and no more than 10 of a[i][j] will be positive integer).
For each test case, there are two integers n and m.(1≤n,m≤50).
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0≤a[i][j]≤100 , and no more than 10 of a[i][j] will be positive integer).
Output
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
Sample Input
3 3
0 0 0
0 100 0
0 0 0
2 2
1 1
1 1
Sample Output
4
4
Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f
#define PI 3.1415926535898
const int maxn = 55;
int mp[maxn][maxn];
int n, m;
int dis[maxn][maxn];
using namespace std;
int dp[12][1<<12];
struct node
{
int x, y;
} f[12];
int main()
{
while(~scanf("%d %d", &n, &m))
{
int ans = 0;
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= m; j++)
{
scanf("%d",&mp[i][j]);
if(mp[i][j])
{
f[ans].x = i;
f[ans++].y = j;
}
}
}
memset(dis, 0, sizeof(dis));
for(int i = 0; i < ans; i++)
for(int j = 0; j < ans; j++) dis[i][j] = (abs(f[i].x-f[j].x)+abs(f[i].y-f[j].y));
for(int i = 0; i < ans; i++)
for(int j = 0; j < (1<<ans); j++) dp[i][j] = INF;
for(int i = 0; i < ans; i++) dp[i][(1<<i)] = (abs(f[i].x-1)+abs(f[i].y-1));
for(int j = 0; j < (1<<ans); j++)
{
for(int k = 0; k < ans; k++)
{
if(!(j&(1<<k))) continue;
for(int p = 0; p < ans; p++)
{
if(j&(1<<p)) continue;
dp[p][j|(1<<p)] = min(dp[k][j] + dis[k][p], dp[p][j|(1<<p)]);
}
}
}
int Min = INF;
for(int i = 0; i < ans; i++) Min = min(Min, dp[i][(1<<ans)-1]+abs(f[i].x-1)+abs(f[i].y-1));
if(Min == INF) Min = 0;
printf("%d\n",Min);
}
return 0;
}
相關文章
- HDU 1074 Doing Homework(狀壓DP)
- HDU 5816 Hearthstone(狀態壓縮DP+概率)
- hdu--5418Victor and World+狀態壓縮DP
- 狀壓 dp
- 狀壓DP
- [狀壓dp] 最短Hamilton路徑(模板題+狀壓dp)
- hdu 2111 Saving HDU (DP)
- 簡易狀態壓縮DP
- 狀壓DP基礎入門
- HDU 3006 The Number of set (狀態壓縮)
- 狀壓 + 網路流 -- Escape HDU - 3605
- hdu 6415 - DP
- 合理安排(狀壓dp,包括技巧)
- NOI2001 炮兵陣地(狀壓dp)
- E - Remove Pairs(狀壓dp+博弈論)REMAI
- HDU6415(DP)
- HDU1024(dp)
- HDU 6415 (計數dp)
- Luogu P1777 幫助 題解 [ 紫 ] [ 線性 dp ] [ 狀壓 dp ]
- 分組(狀壓dp+技巧:快速列舉子集)
- HDU 6415 Rikka with Nash Equilibrium (DP)UI
- Codeforces 11D A Simple Task 題解 [ 藍 ] [ 狀壓 dp ]
- bzoj4145: [AMPPZ2014]The Prices(狀態壓縮+Dp)
- HDU6415:Rikka with Nash Equilibrium(dp)UI
- HDU 6035 Colorful Tree(樹形DP)
- 百練4124:海賊王之偉大航路(狀壓DP)
- HDU 6415(dp/記憶化搜尋)
- HDU4652 Dice(期望dp推式子)
- 一類哈密頓路徑/迴路為背景的狀壓dp
- CF79D Password (差分+狀壓 dp+最短路/bfs)
- HDU多校第九次 6415 (dp
- [狀壓dp]leeccode1434:每個人戴不同帽子的方案數(hard)
- HDU-6415 Rikka with Nash Equilibrium (DP/找規律)UI
- 動態規劃——用二進位制表示集合的狀態壓縮DP動態規劃
- 「暑期訓練」「基礎DP」 Monkey and Banana (HDU-1069)NaN
- 【dp+組合數學】hdu 2018 多校第九場 1001 Rikka with Nash Equilibrium hdu 6415UI
- HDU7458-啟發式合併最佳化DP
- ACM-ICPC 2018 南京賽區網路預賽__E AC Challenge【狀態壓縮+DP】ACM
- dig 命令