HDU 4857 逃生(拓撲排序)

畫船聽雨發表於2014-07-23

BESTCODE的第一題,當時在家沒做,題目敘述很明瞭。就是得注意先後順序。倒著建關係。根據大小用優先佇列向外彈。

逃生

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 633    Accepted Submission(s): 170


Problem Description
糟糕的事情發生啦,現在大家都忙著逃命。但是逃命的通道很窄,大家只能排成一行。

現在有n個人,從1標號到n。同時有一些奇怪的約束條件,每個都形如:a必須在b之前。
同時,社會是不平等的,這些人有的窮有的富。1號最富,2號第二富,以此類推。有錢人就賄賂負責人,所以他們有一些好處。

負責人現在可以安排大家排隊的順序,由於收了好處,所以他要讓1號儘量靠前,如果此時還有多種情況,就再讓2號儘量靠前,如果還有多種情況,就讓3號儘量靠前,以此類推。

那麼你就要安排大家的順序。我們保證一定有解。
 

Input
第一行一個整數T(1 <= T <= 5),表示測試資料的個數。
然後對於每個測試資料,第一行有兩個整數n(1 <= n <= 30000)和m(1 <= m <= 100000),分別表示人數和約束的個數。

然後m行,每行兩個整數a和b,表示有一個約束a號必須在b號之前。a和b必然不同。
 

Output
對每個測試資料,輸出一行排隊的順序,用空格隔開。
 

Sample Input
1 5 10 3 5 1 4 2 5 1 2 3 4 1 4 2 3 1 5 3 5 1 2
 

Sample Output
1 2 3 4 5
 

Author
CLJ
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define MOD 1000000009
const int maxn = 100010;

using namespace std;

vector<int>f[maxn], vec;
priority_queue<int>que;
int in[maxn];
int n, m;
void init()
{
    while(!que.empty()) que.pop();
    memset(in, 0, sizeof(in));
    for(int i = 0; i <= n; i++) f[i].clear();
    vec.clear();
}

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        scanf("%d %d",&n, &m);
        init();
        int x, y;
        for(int i = 1; i <= m; i++)
        {
            scanf("%d %d",&x, &y);
            f[y].push_back(x);
            in[x]++;
        }
        for(int i = 1; i <= n; i++)
            if(!in[i]) que.push(i);
        while(!que.empty())
        {
            int x = que.top();
            que.pop();
            for(int i = 0; i < f[x].size(); i++)
            {
                int v = f[x][i];
                in[v]--;
                if(!in[v])
                    que.push(v);
            }
            vec.push_back(x);
        }
        for(int i = n-1; i > 0; i--)
            printf("%d ",vec[i]);
        cout<<vec[0]<<endl;
    }
    return 0;
}


相關文章