ZOJ 3789 Gears(並查集)
題目大意:給你一些齒輪,然後有的可也組成齒輪組,每個齒輪能夠組合的條件是一個為順時針轉動,一個為逆時針轉動。給你一些操作:
L:給你u,v把u,v連在一起;
D:給你一個u,把u從齒輪組中拿出來;
Q:給你u,v。讓你判斷u和v的轉動方向是否相同;(注意:這裡判斷要首先是同祖先的,然後通過深度差判斷,差為偶數則相同,否則不同)
S:給你一個u,讓你求出這個齒輪所在的齒輪組中一共有多少的齒輪。
解題思路:在儲存祖先的同時在用dis陣列記錄當前節點與祖先節點的距離,同時注意,我們並不是真正的刪除節點我們只是用其他的數子,來代替了這個節點所以。需要用一個mp陣列轉換一下,給的數和實際意義上存的數字。其他的就很好求了啊,注意要壓縮路徑。
Bob has N (1 ≤ N ≤ 2*105) gears (numbered from 1 to N). Each gear can rotate clockwise or counterclockwise. Bob thinks that assembling gears is much more exciting than just playing with a single one. Bob wants to put some gears into some groups. In each gear group, each gear has a specific rotation respectively, clockwise or counterclockwise, and as we all know, two gears can link together if and only if their rotations are different. At the beginning, each gear itself is a gear group.
Bob has M (1 ≤ N ≤ 4*105) operations to his gears group:
- "L u v". Link gear u and gear v. If two gears link together, the gear groups which the two gears come from will also link together, and it makes a new gear group. The two gears will have different rotations. BTW, Bob won't link two
gears with the same rotations together, such as linking (a, b), (b, c), and (a, c). Because it would shutdown the rotation of his gears group, he won't do that.
- "D u". Disconnect the gear u. Bob may feel something wrong about the gear. He will put the gear away, and the gear would become a new gear group itself and may be used again later. And the rest of gears in this group won't be separated apart.
- "Q u v". Query the rotations between two gears u and v. It could be "Different", the "Same" or "Unknown".
- "S u". Query the size of the gears, Bob wants to know how many gears there are in the gear group containing the gear u.
Since there are so many gears, Bob needs your help.
Input
Input will consist of multiple test cases. In each case, the first line consists of two integers N and M. Following M lines, each line consists of one of the operations which are described above. Please process to the end of input.
Output
For each query operation, you should output a line consist of the result.
Sample Input
3 7 L 1 2 L 2 3 Q 1 3 Q 2 3 D 2 Q 1 3 Q 2 3 5 10 L 1 2 L 2 3 L 4 5 Q 1 2 Q 1 3 Q 1 4 S 1 D 2 Q 2 3 S 1
Sample Output
Same Different Same Unknown Different Same Unknown 3 Unknown 2
Hint
Link (1, 2), (2, 3), (4, 5), gear 1 and gear 2 have different rotations, and gear 2 and gear 3 have different rotations, so we can know gear 1 and gear 3 have the same rotation, and we didn't link group (1, 2, 3) and group (4, 5), we don't know the situation about gear 1 and gear 4. Gear 1 is in the group (1, 2, 3), which has 3 gears. After putting gear 2 away, it may have a new rotation, and the group becomes (1, 3).
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 1000100
#define LL __int64
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 1010000;
using namespace std;
int fa[maxn];
int dis[maxn];
int sum[maxn];
int mp[maxn];
int t;
int n, m;
void init()
{
for(int i = 0; i <= n+m; i++)
{
fa[i] = i;
mp[i] = i;
dis[i] = 0;
sum[i] = 1;
}
t = n+1;
}
int Find(int x)
{
if(fa[x] != x)
{
int root = Find(fa[x]);
dis[x] += dis[fa[x]];
return fa[x] = root;
}
return x;
}
int main()
{
char st[10];
while(~scanf("%d %d",&n, &m))
{
init();
int x, y;
for(int i = 0; i < m; i++)
{
scanf("%s",st);
if(st[0] == 'L')
{
scanf("%d %d",&x, &y);
x = mp[x];
y = mp[y];
int tx = Find(x);
int ty = Find(y);
if(tx != ty)
{
sum[tx] += sum[ty];
fa[ty] = tx;
dis[ty] = dis[x]+dis[y]+1;
}
}
else if(st[0] == 'Q')
{
scanf("%d %d",&x, &y);
x = mp[x];
y = mp[y];
int tx = Find(x);
int ty = Find(y);
if(tx != ty)
puts("Unknown");
else
{
if(abs(dis[x]-dis[y])%2 == 0)
puts("Same");
else
puts("Different");
}
}
else if(st[0] == 'D')
{
scanf("%d",&x);
int xx = mp[x];
int tx = Find(xx);
sum[tx] -= 1;
mp[x] = ++t;
}
else if(st[0] == 'S')
{
scanf("%d",&x);
x = mp[x];
int tx = Find(x);
printf("%d\n",sum[tx]);
}
}
}
return 0;
}
相關文章
- zoj 3811||牡丹江網賽 c題 並查集並查集
- 並查集到帶權並查集並查集
- 【並查集】【帶偏移的並查集】食物鏈並查集
- 並查集(一)並查集的幾種實現並查集
- 3.1並查集並查集
- 並查集(小白)並查集
- 並查集(Union Find)並查集
- 並查集應用並查集
- The Door Problem 並查集並查集
- 並查集練習並查集
- 並查集的使用並查集
- 並查集—應用並查集
- 寫模板, 並查集。並查集
- 並查集跳躍並查集
- 各種並查集並查集
- 食物鏈(並查集)並查集
- 並查集(二)並查集的演算法應用案例上並查集演算法
- The Suspects-並查集(4)並查集
- [leetcode] 並查集(Ⅰ)LeetCode並查集
- [leetcode] 並查集(Ⅱ)LeetCode並查集
- [leetcode] 並查集(Ⅲ)LeetCode並查集
- 並查集演算法並查集演算法
- 並查集深度應用並查集
- 【轉】種類並查集並查集
- 並查集java實現並查集Java
- 並查集-Java實現並查集Java
- 並查集題目合集並查集
- 並查集以及應用並查集
- 並查集的應用並查集
- 暢通工程(並查集)並查集
- (Day3)並查集並查集
- 並查集擴充套件並查集套件
- 簡單易懂的並查集演算法以及並查集實戰演練並查集演算法
- 關於並查集問題並查集
- 並查集的應用2並查集
- 並查集の進階用法並查集
- 並查集(UnionFind)技巧總結並查集
- Wireless Network(並查集(裸))並查集