POJ 2492 A Bug's Life(關係並查集)

畫船聽雨發表於2014-02-28

題意就是找出蟲子之間是否有同性戀。。。。這個蟲子真的很趕潮流啊,竟然也搞基、、、

跟1703一樣的關係並查集。

A Bug's Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 26105   Accepted: 8513

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 101000;

using namespace std;

int f[maxn];
int w[maxn];
int r;


int _find(int x)
{
    int t = x;
    r = 0;
    while(x != f[x])
    {
        if(w[x])
        {
            if(r == 1)
                r = 0;
            else
                r = 1;
        }
        x = f[x];
    }
    f[t] = x;
    w[t] = r;
    return x;
}


int main()
{
    int t;
    cin >>t;
    int n, m;
    for(int k = 1; k <= t; k++)
    {
        scanf("%d %d",&n,&m);
        for(int i = 0; i <= n; i++)
        {
            f[i] = i;
            w[i] = 0;
        }
        int flat = 0;
        while(m--)
        {
            int x, y;
            scanf("%d %d",&x, &y);
            int xx = _find(x);
            int r1 = r;
            int yy = _find(y);
            int r2 = r;
            if(xx == yy)
            {
                if(r1 == r2)
                {
                    flat = 1;
                    continue;
                }
            }
            else
            {
                f[xx] = yy;
                if(r1 == r2)
                    w[xx] = 1;
                else
                    w[xx] = 0;
            }
        }
       printf("Scenario #%d:\n", k);
        if(flat)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        puts("");
    }
    return 0;
}


相關文章