HDU 1556 Color the ball 線段樹入門題
典型的線段樹,區間的更新,統計區間內元素的和。
Color the ball
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7031 Accepted Submission(s): 3668
Problem Description
N個氣球排成一排,從左到右依次編號為1,2,3....N.每次給定2個整數a b(a <= b),lele便為騎上他的“小飛鴿"牌電動車從氣球a開始到氣球b依次給每個氣球塗一次顏色。但是N次以後lele已經忘記了第I個氣球已經塗過幾次顏色了,你能幫他算出每個氣球被塗過幾次顏色嗎?
Input
每個測試例項第一行為一個整數N,(N <= 100000).接下來的N行,每行包括2個整數a b(1 <= a <= b <= N)。
當N = 0,輸入結束。
當N = 0,輸入結束。
Output
每個測試例項輸出一行,包括N個整數,第I個數代表第I個氣球總共被塗色的次數。
Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 1000100;
using namespace std;
struct node
{
int a, b;
int cnum;
}f[maxn*4];
int num[maxn];
void Bulid(int l, int r, int site)
{
if(l == r)
{
f[site].a = l;
f[site].b = l;
f[site].cnum = 0;
return;
}
int mid = (l+r)>>1;
Bulid(l, mid, site<<1);
Bulid(mid+1, r, site<<1|1);
f[site].a = l;
f[site].b = r;
f[site].cnum = 0;
}
void Search(int l, int r, int site)
{
if(f[site].a == l && f[site].b == r)
{
f[site].cnum++;
return;
}
else
{
int mid = (f[site].a+f[site].b)>>1;
if(r <= mid)
{
Search(l, r, site<<1);
}
else if(l > mid)
{
Search(l, r, site<<1|1);
}
else
{
Search(l, mid, site<<1);
Search(mid+1, r, site<<1|1);
}
}
}
void Find(int x)
{
int i;
for(i = f[x].a; i<=f[x].b; i++)//該區間所有編號都被刷了一次
num[i]+=f[x].cnum;
if(f[x].a == f[x].b)
return;
Find(x<<1);
Find(x<<1|1);
}
int main()
{
int n;
int a, b;
while(scanf("%d",&n) && n != 0)
{
Bulid(1, n, 1);
for(int i = 1; i <= n; i++)
{
scanf("%d %d",&a, &b);
Search(a, b, 1);
}
memset(num, 0 , sizeof(num));
Find(1);
for(int i = 1; i <= n-1; i++)
printf("%d ",num[i]);
printf("%d\n",num[n]);
}
return 0;
}
相關文章
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- HDU 1556-Color the ball(樹狀陣列-區間修改 單點查詢)陣列
- POJ 2777 Count Color 線段樹入門題
- 【樹狀陣列 區間修改,單點求值】1556 Color the ball陣列
- HDU 1754 I Hate It 線段樹入門
- HDU 1166 敵兵佈陣 線段樹入門題目
- 線段樹入門
- 線段樹入門理解
- 線段樹 transformation——hdu 4578ORM
- 線段樹入門(Segment Tree)
- hdu 1754 I Hate It (線段樹)
- (hdu 1166)敵兵佈陣(線段樹入門,單點更新)
- Transformation HDU - 4578線段樹綜合操作ORM
- hdu 1754 【線段樹/RMQ】I Hate ItMQ
- hdu 3973 字串hash+線段樹字串
- 線段樹模版:從入門到入墳
- hdu4288 離線處理線段樹
- hdu 4836 The Query on the Tree(線段樹or樹狀陣列)陣列
- POJ 2582 Mayor's posters 線段樹入門題+離散化
- HDU 1754 I Hate It (線段樹 區間最值)
- hdu 1394 Minimum Inversion Number 【線段樹查詢】
- HDU 1698 Just a Hook (線段樹區間更新)Hook
- POJ 2828 Buy Tickets 線段樹入門(建樹稍微有點抽象)抽象
- hdu 2665 可持久化線段樹求區間第K大值(函式式線段樹||主席樹)持久化函式
- HDU 3333 Turing Tree(線段樹+離線操作)
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- HDU 3074 Multiply game(線段樹 單點更新)GAM
- (hdu 1754) I Hate It(線段樹基礎,單點更新)
- POJ 2777-Count Color(線段樹-區間染色查詢)
- 線段樹也能是 Trie 樹 題解
- 線~段~樹
- 線段樹
- 線段樹 hate it
- 【模版】線段樹
- 01 線段樹
- 線段樹--RMQMQ
- 李超線段樹
- 線段樹模板