POJ 3070 Fibonacci(需要繼續學習)
構造矩陣與矩陣的快速冪取模。。。寶哥給講的演算法原理,程式碼是學的別人的,先寫一下回頭還得再研究。
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8121 | Accepted: 5774 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 100100
#define LL __int64
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
using namespace std;
struct node
{
int dp[2][2];
};
node ad;
int n, mod;
node mul(node a, node b)
{
node t;
int i, j, k;
memset(t.dp, 0 , sizeof(t.dp));
for(i = 0; i < 2; i++)
{
for(k = 0; k < 2; k++)
{
if(a.dp[i][k])
{
for(j = 0; j < 2; j++)
{
t.dp[i][j] += a.dp[i][k]*b.dp[k][j];
if(t.dp[i][j] > mod)
t.dp[i][j] %= mod;
}
}
}
}
return t;
}
node expo(node p, int k)
{
if(k == 1) return p;
node e;
int i;
memset(e.dp , 0 , sizeof(e.dp));
for(i = 0; i < n; i++) e.dp[i][i] = 1;
if(k == 0)
return e;
while(k)
{
if(k&1) e = mul(p,e);
p = mul(p, p);
k >>= 1;
}
return e;
}
int main()
{
n = 2;
mod = 10000;
int k;
ad.dp[1][1] = 0;
ad.dp[0][1] = ad.dp[1][0] = ad.dp[0][0] = 1;
while(cin >>k)
{
if(k == -1)
break;
node t = expo(ad, k);
int ans = t.dp[0][1]%mod;
cout <<ans<<endl;
}
return 0;
}
相關文章
- POJ3070 Fibonacci[矩陣乘法]【學習筆記】矩陣筆記
- JAVA GUI學習 繼續JavaGUI
- 工作以後難道就不需要繼續學習了嗎
- JS繼續學習記錄(一)JS
- C#快速入門教程(30)—— 繼續學習C#
- 需要同時掌握AVA和Linux,才可以繼續大資料課程的學習Linux大資料
- Linux運維需要持續學習嗎?Linux學習Linux運維
- 繼續學習webpack4的一些配置總結Web
- 周朝陽:我的2017年繼續教育學習二三事
- 77%的IT業人員擬繼續學習IT知識以防落伍
- 華瑞IT學校:高考沒被錄取,繼續學習的途徑有哪些
- 持續學習
- 還有沒有必要繼續再學oracle?Oracle
- JavaScript 學習之繼承JavaScript繼承
- Oracle RMAN練習繼續,簡單涉及CatalogOracle
- HTML 學習待續HTML
- java學習之旅(續)Java
- JAVA學習筆記-繼承Java筆記繼承
- Scala學習(八)---Scala繼承繼承
- 130701基礎練習-first
- java繼續革命(轉)Java
- 奧運會結束了,生活還要繼續,工作還要繼續...
- 學習進度 (待續)
- 續rman學習筆記筆記
- Java學習筆記之繼承Java筆記繼承
- JavaScript學習3:原型和繼承JavaScript原型繼承
- Java需要學習的東東Java
- 想要學習web前端需要學習那些課程Web前端
- 如果要學習web前端,需要學習什麼Web前端
- 繼續完成驗證碼
- 強化學習-學習筆記15 | 連續控制強化學習筆記
- 學習大資料需要掌握的知識,需要學習的資料技術大資料
- java學習——物件導向之繼承Java物件繼承
- 九. Go學習:Go中的繼承Go繼承
- CSS學習摘要-層疊和繼承CSS繼承
- JavaSE基礎知識學習-----繼承Java繼承
- Javaweb都有哪些框架需要學習?JavaWeb框架
- 繼續聊聊MVVM和元件化MVVM元件化