【杭電oj】1222 - Wolf and Rabbit(GCD)

離殤灬孤狼發表於2016-07-18

點選開啟題目

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7109    Accepted Submission(s): 3563


Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input
2 1 2 2 2
 

Sample Output
NO YES
 

Author
weigang Lee
 

Source



剛開始用的map模擬,結果爆記憶體了。

後來想了想,就是個GCD,如果兩個數互質,那麼每個點都能掃到;如果不互質,總會形成迴圈從而漏掉某些洞口。


程式碼如下:

#include <cstdio>
int GCD(int a,int b)
{
	if (a % b == 0)
		return b;
	return GCD(b,a%b);
}
int main()
{
	int u;
	int n,k;
	scanf ("%d",&u);
	while (u--)
	{
		scanf ("%d %d",&k,&n);
		if (GCD(n,k) == 1)
			printf ("NO\n");
		else
			printf ("YES\n");
	}
	return 0;
}


相關文章