HYSBZ 2243 樹鏈剖分(區間更新,區間查詢)較難

life4711發表於2015-05-30

http://www.lydsy.com/JudgeOnline/problem.php?id=2243

Description

給定一棵有n個節點的無根樹和m個操作,操作有2類:

1、將節點a到節點b路徑上所有點都染成顏色c

2、詢問節點a到節點b路徑上的顏色段數量(連續相同顏色被認為是同一段),如“1122213段組成:“11、“222和“1

請你寫一個程式依次完成這m個操作。

Input

第一行包含2個整數nm,分別表示節點數和運算元;

第二行包含n個正整數表示n個節點的初始顏色

下面 行每行包含兩個整數xy,表示xy之間有一條無向邊。

下面 行每行描述一個操作:

“C a b c”表示這是一個染色操作,把節點a到節點b路徑上所有點(包括ab)都染成顏色c

“Q a b”表示這是一個詢問操作,詢問節點a到節點b(包括ab)路徑上的顏色段數量。

Output

對於每個詢問操作,輸出一行答案。

Sample Input

6 5
2 2 1 2 1 1
1 2
1 3
2 4
2 5
2 6
Q 3 5
C 2 1 1
Q 3 5
C 5 1 2
Q 3 5

Sample Output

3
1
2

HINT

數N<=10^5,運算元M<=10^5,所有的顏色C為整數且在[0, 10^9]之間。

/***
HYSBZ 2243 樹鏈剖分(區間更新,區間查詢)
解題思路:這道題轉化成線段樹後需要維護三個值:區間左邊界的顏色,區間右邊界的顏色,區間的顏色段數。在樹查詢的時候要注意排重的技巧,詳見程式碼
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=100005;
int fa[maxn],dep[maxn],siz[maxn],son[maxn],num[maxn],top[maxn];
int n,p,z,a[maxn],Hash[maxn];
int ll[maxn*4],rr[maxn*4],tree[maxn*4],flag[maxn*4];
int head[maxn],ip;

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

struct note
{
    int v,next;
} edge[maxn*2];

void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}

void dfs(int u,int pre)
{
    son[u]=0,siz[u]=1,dep[u]=dep[pre]+1,fa[u]=pre;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==pre)continue;
        dfs(v,u);
        siz[u]+=siz[v];
        if(siz[son[u]]<siz[v])
            son[u]=v;
    }
   // printf("%d fa dep son siz %d %d %d %d\n",u,fa[u],dep[u],son[u],siz[u]);
}
void init_que(int u ,int tp)
{
    num[u]=++z,top[u]=tp,Hash[z]=u;
    if(son[u])
    {
        init_que(son[u],tp);
    }
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==fa[u]||v==son[u])continue;
        init_que(v,v);
    }
    //printf("%d num top %d %d\n",u,num[u],top[u]);
}
void push_down(int root)
{
    if(flag[root])
    {
        tree[root<<1]=tree[root<<1|1]=1;
        ll[root<<1]=ll[root<<1|1]=rr[root<<1]=rr[root<<1|1]=ll[root];
        flag[root<<1]=flag[root<<1|1]=1;
        flag[root]=0;
    }
}

void push_up(int root)
{
    if(ll[root<<1|1]==rr[root<<1])
        tree[root]=tree[root<<1]+tree[root<<1|1]-1;
    else
        tree[root]=tree[root<<1]+tree[root<<1|1];
    ll[root]=ll[root<<1];
    rr[root]=rr[root<<1|1];
}

void build(int root,int l,int r)
{
    flag[root]=0;
    if(l==r)
    {
        tree[root]=1;
        ll[root]=rr[root]=a[Hash[l]];
        return;
    }
    int mid=(l+r)>>1;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);
    push_up(root);
}
void update(int root,int l,int r,int x,int y,int z)
{
    if(l>y||r<x)return;
    if(x<=l&&r<=y)
    {
        flag[root]=1;
        tree[root]=1;
        ll[root]=z;
        rr[root]=z;
        return;
    }
    push_down(root);
    int mid=(l+r)>>1;
    update(root<<1,l,mid,x,y,z);
    update(root<<1|1,mid+1,r,x,y,z);
    push_up(root);
}
int query(int root,int l,int r,int x,int y)
{
    if(x<=l&&r<=y)
    {
        return tree[root];
    }
    push_down(root);
    int sum=0;
    int mid=(l+r)>>1;
    if(y<=mid)
        return query(root<<1,l,mid,x,y);
    else if(x>mid)
        return query(root<<1|1,mid+1,r,x,y);
    else
    {
        int sum=query(root<<1|1,mid+1,r,x,y)+query(root<<1,l,mid,x,y);
        if(ll[root<<1|1]==rr[root<<1])
            sum--;
        return sum;
    }
}

int query1(int root,int l,int r,int loc)
{
    if(l==r)
    {
        return ll[root];
    }
    push_down(root);
    int mid=(l+r)>>1;
    if(loc<=mid)
        return query1(root<<1,l,mid,loc);
    else
        return query1(root<<1|1,mid+1,r,loc);
}
int main()
{
  //  freopen("data.txt","r",stdin);
    while(~scanf("%d%d",&n,&p))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        init();
        for(int i=1; i<n; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            addedge(x,y);
            addedge(y,x);
        }
        z=0,siz[0]=0,dep[0]=0;
        dfs(1,0);
        init_que(1,1);
        build(1,1,z);
        while(p--)
        {
            char s[10];
            int x,y,zz;
            scanf("%s",s);
            if(s[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                int f1=top[x],f2=top[y],sum=0;
                while(f1!=f2)
                {
                    if(dep[f1]<dep[f2])
                    {
                        swap(f1,f2);
                        swap(x,y);
                    }
                    sum+=query(1,1,z,num[f1],num[x]);
                    if(query1(1,1,z,num[f1])==query1(1,1,z,num[fa[f1]]))
                    {
                        sum--;
                    }
                    x=fa[f1],f1=top[x];
                }
                if(dep[x]>dep[y])
                    swap(x,y);
                sum+=query(1,1,z,num[x],num[y]);
                printf("%d\n",sum);
            }
            else
            {
                scanf("%d%d%d",&x,&y,&zz);
                int f1=top[x],f2=top[y];
                while(f1!=f2)
                {
                    if(dep[f1]<dep[f2])
                    {
                        swap(f1,f2);
                        swap(x,y);
                    }
                    update(1,1,z,num[f1],num[x],zz);
                    x=fa[f1],f1=top[x];
                }
                if(dep[x]>dep[y])
                    swap(x,y);
                update(1,1,z,num[x],num[y],zz);
            }
        }
    }
    return 0;
}


相關文章