hdu2896 AC自動機-標記哪些模式串在目標串中出現過

life4711發表於2015-04-27

http://acm.hdu.edu.cn/showproblem.php?pid=2896

Problem Description
當太陽的光輝逐漸被月亮遮蔽,世界失去了光明,大地迎來最黑暗的時刻。。。。在這樣的時刻,人們卻異常興奮——我們能在有生之年看到500年一遇的世界奇觀,那是多麼幸福的事兒啊~~
但網路上總有那麼些網站,開始藉著民眾的好奇心,打著介紹日食的旗號,大肆傳播病毒。小t不幸成為受害者之一。小t如此生氣,他決定要把世界上所有帶病毒的網站都找出來。當然,誰都知道這是不可能的。小t卻執意要完成這不能的任務,他說:“子子孫孫無窮匱也!”(愚公後繼有人了)。
萬事開頭難,小t收集了好多病毒的特徵碼,又收集了一批詭異網站的原始碼,他想知道這些網站中哪些是有病毒的,又是帶了怎樣的病毒呢?順便還想知道他到底收集了多少帶病毒的網站。這時候他卻不知道何從下手了。所以想請大家幫幫忙。小t又是個急性子哦,所以解決問題越快越好哦~~
 

Input
第一行,一個整數N(1<=N<=500),表示病毒特徵碼的個數。
接下來N行,每行表示一個病毒特徵碼,特徵碼字串長度在20—200之間。
每個病毒都有一個編號,依此為1—N。
不同編號的病毒特徵碼不會相同。
在這之後一行,有一個整數M(1<=M<=1000),表示網站數。
接下來M行,每行表示一個網站原始碼,原始碼字串長度在7000—10000之間。
每個網站都有一個編號,依此為1—M。
以上字串中字元都是ASCII碼可見字元(不包括回車)。
 

Output
依次按如下格式輸出按網站編號從小到大輸出,帶病毒的網站編號和包含病毒編號,每行一個含毒網站資訊。
web 網站編號: 病毒編號 病毒編號 …
冒號後有一個空格,病毒編號按從小到大排列,兩個病毒編號之間用一個空格隔開,如果一個網站包含病毒,病毒數不會超過3個。
最後一行輸出統計資訊,如下格式
total: 帶病毒網站數
冒號後有一個空格。
 

Sample Input
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
web 1: 1 2 3 total: 1

/**
hdu2896  AC自動機-標記哪些模式串在目標串中出現過
題目大意:給定一些模式串,和一些目標串,找出在每一個目標串中有哪些模式串出現過,和總共出現模式串的目標串的個數
解題思路:AC自動機模板題,只需要對每一模式串標記一下就可以了
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
struct Trie
{
    int next[210*500][128],fail[210*500],end[210*500];
    int root,L;
    int newnode()
    {
        for(int i=0;i<128;i++)
        {
            next[L][i]=-1;
        }
        end[L++]=-1;
        return L-1;
    }
    void init()
    {
        L=0;
        root=newnode();
    }
    void insert(char *s,int id)
    {
        int len=strlen(s);
        int now=root;
        for(int i=0;i<len;i++)
        {
            if(next[now][s[i]]==-1)
                next[now][s[i]]=newnode();
            now=next[now][s[i]];
        }
        end[now]=id;
    }
    void build()
    {
        queue<int>Q;
        fail[root]=root;
        for(int i=0;i<128;i++)
        {
            if(next[root][i]==-1)
                next[root][i]=root;
            else
            {
                fail[next[root][i]]=root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty())
        {
            int now=Q.front();
            Q.pop();
            for(int i=0;i<128;i++)
            {
                if(next[now][i]==-1)
                    next[now][i]=next[fail[now]][i];
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    Q.push(next[now][i]);
                }
            }
        }
    }
    bool used[510];
    bool query(char *buf,int n,int id)
    {
        int len=strlen(buf);
        int now=root;
        memset(used,false,sizeof(used));
        bool flag=false;
        for(int i=0;i<len;i++)
        {
            now=next[now][buf[i]];
            int temp=now;
            while(temp!=root)
            {
                if(end[temp]!=-1)
                {
                    used[end[temp]]=true;
                    flag=true;
                }
                temp=fail[temp];
            }
        }
        if(!flag)return false;
        printf("web %d:",id);
        for(int i=1;i<=n;i++)
        {
            if(used[i])
                printf(" %d",i);
        }
        printf("\n");
        return true;
    }
}ac;
char buf[10010];
int main()
{
    int m,n;
    while(scanf("%d",&n)!=EOF)
    {
        ac.init();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",buf);
            ac.insert(buf,i);
        }
        ac.build();
        int ans=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%s",buf);
            if(ac.query(buf,n,i))
                ans++;
        }
        printf("total: %d\n",ans);
    }
    return 0;
}


相關文章