hdu1251 字典樹的應用(查詢公共字首)

life4711發表於2015-04-23

http://acm.hdu.edu.cn/showproblem.php?pid=1251

Problem Description
Ignatius最近遇到一個難題,老師交給他很多單詞(只有小寫字母組成,不會有重複的單詞出現),現在老師要他統計出以某個字串為字首的單詞數量(單詞本身也是自己的字首).
 

Input
輸入資料的第一部分是一張單詞表,每行一個單詞,單詞的長度不超過10,它們代表的是老師交給Ignatius統計的單詞,一個空行代表單詞表的結束.第二部分是一連串的提問,每行一個提問,每個提問都是一個字串.

注意:本題只有一組測試資料,處理到檔案結束.
 

Output
對於每個提問,給出以該字串為字首的單詞的數量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0
/**
hdu 1251 Tire樹(字典樹)的應用
解題思路:構造字典樹,查詢公共字首的個數,算是個模板吧
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
struct node
{
    int count;
    node *childs[26];
    node()
    {
        count=0;
        for(int i=0;i<26;i++)
        {
            childs[i]=NULL;
        }
    }
};

node *root=new node;
node *current,*newnode;

void insert(char *str)
{
    current=root;
    int len=strlen(str);
    for(int i=0;i<len;i++)
    {
        int m=str[i]-'a';
        if(current->childs[m]!=NULL)
        {
            current=current->childs[m];
            ++(current->count);
        }
        else
        {
            newnode=new node;
            ++(newnode->count);
            current->childs[m]=newnode;
            current=newnode;
        }
    }
}

int search(char *str)
{
    current=root;
    int len=strlen(str);
    for(int i=0;i<len;i++)
    {
        int m=str[i]-'a';
        if(current->childs[m]==NULL)
            return 0;
        current=current->childs[m];
    }
    return current->count;
}

int main()
{
    char str[20];
    while(gets(str),strcmp(str,""))
    {
        insert(str);
    }
    while(gets(str)!=NULL)
    {
        printf("%d\n",search(str));
    }
    return 0;
}


相關文章