poj1087 網路最大流

life4711發表於2015-01-20

http://poj.org/problem?id=1087

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1
/**
poj 1087  網路最大流
題目大意:(思路摘自網上)這題題目意思實在太難懂,不過題目意思搞清楚之後還是比較好做的
在這個題目裡有兩種物品,一個是插座,一個是電器
插座只有一個插孔和一個插頭,電器只有一個插頭
首先有n種插座,n種插座用字串表示,這n種插座可以理解為是插在電源上的插座
然後有m個電器,現在電器要充電,電器用字串表示,每個電器都有自己可以插的插座
(這個插座可以不是那n個插在電源上的插座,可以是其他的插座)
現在有k個資訊
s1 s2代表s1插座可以插到s2插座上去,這裡類似於將插頭轉換了一下
這些s1與s2也可以不是那n個插在電源上的插座
給出這些個資訊問你還有多少個電器沒有插座可以用

解題思路:
建一個源點,指向所有電器,容量為1
所有電器指向他們可以插的那個插頭上,容量為1
如果一個插頭可以插到另一個插頭,那麼將s1指向s2,容量為無限大
將所有插在電源上的插頭指向匯點,容量為1

然後從源點到匯點求最大流即可
*/
#include<cstdio>
#include <string.h>
#include<iostream>
using namespace std;
const int oo=1e9;
/**oo 表示無窮大*/
const int mm=111111;
/**mm 表示邊的最大數量,記住要是原圖的兩倍,在加邊的時候都是雙向的*/
const int mn=999;
/**mn 表示點的最大數量*/

char name[3000][30];
int k;
int node,src,dest,edge;
/**node 表示節點數,src 表示源點,dest 表示匯點,edge 統計邊數*/
int ver[mm],flow[mm],next[mm];
/**ver 邊指向的節點,flow 邊的容量,next 連結串列的下一條邊*/
int head[mn],work[mn],dis[mn],q[mn];
/**head 節點的連結串列頭,work 用於演算法中的臨時連結串列頭,dis 計算距離*/

/**初始化連結串列及圖的資訊*/
void prepare(int _node,int _src,int _dest)
{
    node=_node,src=_src,dest=_dest;
    for(int i=0; i<node; ++i)head[i]=-1;
    edge=0;
}
/**增加一條u 到v 容量為c 的邊*/
void addedge(int u,int v,int c)
{
    ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}
/**廣搜計算出每個點與源點的最短距離,如果不能到達匯點說明演算法結束*/
bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=src]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=next[i])
            if(flow[i]&&dis[v=ver[i]]<0)
            {
                /**這條邊必須有剩餘容量*/
                dis[q[r++]=v]=dis[u]+1;
                if(v==dest)return 1;
            }
    return 0;
}
/**尋找可行流的增廣路演算法,按節點的距離來找,加快速度*/
int Dinic_dfs(int u,int exp)
{
    if(u==dest)return exp;
    /**work 是臨時連結串列頭,這裡用i 引用它,這樣尋找過的邊不再尋找*/
    for(int &i=work[u],v,tmp; i>=0; i=next[i])
        if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
        {
            flow[i]-=tmp;
            flow[i^1]+=tmp;
            /**正反向邊容量改變*/
            return tmp;
        }
    return 0;
}
int Dinic_flow()
{
    int i,ret=0,delta;
    while(Dinic_bfs())
    {
        for(i=0; i<node; ++i)work[i]=head[i];
        while(delta=Dinic_dfs(src,oo))ret+=delta;
    }
    return ret;
}

int sol(char *str)
{
    int i;
    if(k==0)
    {
        strcpy(name[1],str);
        k=1;
        return  1;
    }
    for(i=1; i<=k; i++)
        if(strcmp(name[i],str)==0)
            return i;
    k++;
    strcpy(name[k],str);
    return k;
}

int main()
{
    int n1,n2,n3;
    int st,ed;
    int a,b;
    int num1[105][2],num2[105][2],num3[105][2];
    char str1[30],str2[30];
    while(~scanf("%d",&n1))
    {
        k=0;
        for(int i=0;i<n1;i++)
        {
            scanf("%s",str1);
            num1[i][0]=sol(str1);
        }
        scanf("%d",&n2);
        for(int i=0;i<n2;i++)
        {
            scanf("%s%s",str1,str2);
            num2[i][0]=sol(str1);
            num2[i][1]=sol(str2);
        }
        scanf("%d",&n3);
        for(int i=0;i<n3;i++)
        {
            scanf("%s%s",str1,str2);
            num3[i][0]=sol(str1);
            num3[i][1]=sol(str2);
        }
        prepare(k+2,0,k+1);

        for(int i=0;i<n1;i++)
        {
            addedge(num1[i][0],dest,1);
        }
        for(int i=0;i<n2;i++)
        {
            addedge(num2[i][0],num2[i][1],1);
            addedge(src,num2[i][0],1);
        }
        for(int i=0;i<n3;i++)
        {
            addedge(num3[i][0],num3[i][1],oo);
        }
        printf("%d\n",n2-Dinic_flow());
    }
    return 0;
}


相關文章