poj 3349 陣列的hash(最常用、最普通的雜湊表建立)

life4711發表於2015-01-01

http://poj.org/problem?id=3349

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.
/**
poj 3349  數字hash
題目大意:每個雪花都有六個分支,用六個整數代表,這六個整數是從任意一個分支開始,朝順時針或逆時針方向遍歷得到的。輸入多個雪花,判斷是否有形狀一致的雪花存在。
解題思路:數字雜湊,要注意的是每種雪花可以由多種數字組合表示。
比如輸入的是1 2 3 4 5 6,
則2 3 4 5 6 1,3 4  5 6 1 2,……,6 5 4 3 2 1,5 4 3 2 1 6等都是相同形狀的。
因此可以在讀入一個雪花的時候把這些情況全部放入雜湊表中,如果某次插入的時候發生衝突,則說明存在重複的雪花,並且後面的不需要再處理。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long LL;
const int maxn=1200010;
const int mod=1200007;

int head[maxn],ip;

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}
struct note
{
    int num[6];
    int next;
} edge[1200010];

int get_hash(int *num)
{
    int h=0;
    for(int i=0; i<6; i++)
        h+=num[i];///雜湊函式,也可以用其他的構造方式
    return h%mod;
}

void insert_hash(int *num,int h)
{
    for(int i=0; i<6; i++)
        edge[ip].num[i]=num[i];
    edge[ip].next=head[h];
    head[h]=ip;
    ip++;

}

bool compare(int *a,int *b)
{
    for(int i=0; i<6; i++)
    {
        if(a[i]!=b[i])
            return false;
    }
    return true;
}

bool search_hash(int *num)
{
    int h=get_hash(num);
    for(int i=head[h]; i!=-1; i=edge[i].next)
    {
        if(compare(num,edge[i].num))
            return true;
    }
    insert_hash(num,h);
    return false;
}

int main()
{
    int n,num[2][15];
    scanf("%d",&n);
    init();
    int flag=0;
    while(n--)
    {
        for(int i=0; i<6; i++)
        {
            scanf("%d",&num[0][i]);
            num[0][i+6]=num[0][i];
        }
        if(flag) continue;
        for(int i=0; i<6; i++)
        {
            num[1][i+6]=num[1][i]=num[0][5-i];
        }
        for(int i=0; i<6; i++)
        {
            if(search_hash(num[0]+i)||search_hash(num[1]+i))
            {
                flag=1;
                break;
            }
        }
    }
    if(flag)printf("Twin snowflakes found.\n");
    else printf("No two snowflakes are alike.\n");
    return 0;
}


相關文章