AC dreamoj 1011 樹狀陣列+hash維護字串的字首和
http://acdream.info/problem?pid=1019
Problem Description
Now we have a long long string, and we will have two kinds of operation on it.
C i y : change the ith letter to y.
Q i j : check whether the substring from ith letter to jth letter is a palindrome.
Input
There are multiple test cases.
The first line contains a string whose length is not large than 1,000,000.
The next line contains a integer N indicating the number of operations.
The next N lines each lines contains a operation.
All letters in the input are lower-case.
Output
For each query operation, output "yes" if the corresponding substring is a palindrome, otherwise output "no".
Sample Input
aaaaa 4 Q 1 5 C 2 b Q 1 5 Q 1 3
Sample Output
yes no yes
/**
ACdreamoj 1019 樹狀陣列+hash維護字串的字首和
題目大意:
給定一個字串,單點更新,區間查詢該區間是不是迴文串。
解題思路:
hash是x1 * p^1+ x2*p^2 +x3*p^3...可以用樹狀陣列維護字首和,
維護兩個串,一個是正串,另一個是反串用於比較。
字串區間s[l~r]的雜湊值為sum(s[r]-s[l-1])/Hash[l-1];
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
typedef unsigned long long LL;
const int maxn=1000010;
const int seed=13;
LL Hash[maxn],C[2][maxn];
char s[maxn];
int len;
void init()
{
Hash[0]=1;
for(int i=1;i<maxn;i++)
Hash[i]=Hash[i-1]*seed;
}
int lowbit(int x)
{
return x&(-x);
}
void add(int i,int x,LL pos)
{
while(x<=len)
{
C[i][x]+=pos;
x+=lowbit(x);
}
}
LL sum(int i,int x)
{
LL ans=0;
while(x)
{
ans+=C[i][x];
x-=lowbit(x);
}
return ans;
}
LL gethash(int i,int l,int r)
{
return sum(i,r)-sum(i,l-1);
}
int main()
{
init();
while(~scanf("%s",s+1))
{
memset(C,0,sizeof(C));
len=strlen(s+1);
for(int i=1;i<=len;i++)
{
add(0,i,(s[i]-'a')*Hash[i]);
add(1,len+1-i,(s[i]-'a')*Hash[len+1-i]);
}
int T;
cin >> T;
while(T--)
{
char c[5];
scanf("%s",c);
if(c[0]=='C')
{
char b[5];
int a;
scanf("%d%s",&a,b);
add(0,a,(b[0]-s[a])*Hash[a]);
add(1,len+1-a,(b[0]-s[a])*Hash[len+1-a]);
s[a]=b[0];
}
else
{
int l,r;
scanf("%d%d",&l,&r);
if(gethash(0,l,r)*Hash[len-r]==gethash(1,len+1-r,len+1-l)*Hash[l-1])//採用交叉相乘把除換成了乘
puts("yes");
else
puts("no");
}
}
}
return 0;
}
相關文章
- hdu 4368 樹狀陣列 離線維護陣列
- 二維樹狀陣列陣列
- AC自動機+字典序+樹狀陣列陣列
- HDU5147 Sequence II(樹狀陣列+字首和+字尾和)陣列
- 樹狀陣列和逆序對陣列
- 樹狀陣列陣列
- Leetcode 327. 區間和的個數 (字首和 + 離散化 + 樹狀陣列)LeetCode陣列
- 【二維樹狀陣列】poj 2155 Matrix陣列
- 二維樹狀陣列-poj2155陣列
- poj 1195 二維樹狀陣列陣列
- 關於區間操作查詢(字首和與差分)+樹狀陣列基礎陣列
- 解析樹狀陣列陣列
- 維護樹狀資料
- 二維樹狀陣列--poj1195陣列
- [php]運用變數引用實現一維陣列轉多維樹狀陣列PHP變數陣列
- POJ 1195 Mobile phones(二維樹狀陣列)陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- poj 2481 樹狀陣列陣列
- hdu 3874 樹狀陣列陣列
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- hdu 5147 樹狀陣列陣列
- 【筆記/模板】樹狀陣列筆記陣列
- 樹狀陣列快速入門陣列
- 陣列和字串陣列字串
- 2014多校聯合第9場1011題||hdu 4970 樹狀陣列陣列
- light oj 1080 線段樹和樹狀陣列陣列
- CF 293 E Close Vertices (樹的分治+樹狀陣列)陣列
- 樹狀陣列模板+習題集陣列
- 樹狀陣列3種基本操作陣列
- 學習筆記----樹狀陣列筆記陣列
- 樹狀陣列upc1976陣列
- CSU 4441 Necklace (樹狀陣列/LIS)陣列
- 樹狀陣列(我是真小白)陣列
- 資料結構——樹狀陣列資料結構陣列
- 線段樹+差分——【模板】樹狀陣列2陣列
- hdu 4836 The Query on the Tree(線段樹or樹狀陣列)陣列